summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-10-01 21:53:15 +1300
committerKent Fredric <kentnl@gentoo.org>2020-10-01 21:53:30 +1300
commit79ef074061ca5590a7cb81bb4bea78a688336b59 (patch)
tree03c756086e16d4876b634063ed1464c89b705298 /dev-perl/File-RsyncP
parentsci-calculators/units: Install for multiple python implementations (diff)
downloadgentoo-79ef074061ca5590a7cb81bb4bea78a688336b59.tar.gz
gentoo-79ef074061ca5590a7cb81bb4bea78a688336b59.tar.bz2
gentoo-79ef074061ca5590a7cb81bb4bea78a688336b59.zip
dev-perl/File-RsyncP: Bump to version 0.760.0
Upstream: - Correctly handle stderr output from rsync 3.2.3 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/File-RsyncP')
-rw-r--r--dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild34
-rw-r--r--dev-perl/File-RsyncP/Manifest1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild b/dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild
new file mode 100644
index 000000000000..8f1d9c6227ff
--- /dev/null
+++ b/dev-perl/File-RsyncP/File-RsyncP-0.760.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CBARRATT
+DIST_VERSION=0.76
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="An rsync perl module"
+HOMEPAGE="http://perlrsync.sourceforge.net/ https://metacpan.org/release/File-RsyncP"
+# Bundled files make for some weirdness
+LICENSE="GPL-3+ GPL-2+ RSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=virtual/perl-Getopt-Long-2.240.0
+ net-misc/rsync
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.700.0-make.patch" )
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/File-RsyncP/Manifest b/dev-perl/File-RsyncP/Manifest
index 5c301135c24f..f57c4d163b8f 100644
--- a/dev-perl/File-RsyncP/Manifest
+++ b/dev-perl/File-RsyncP/Manifest
@@ -1 +1,2 @@
DIST File-RsyncP-0.74.tar.gz 167122 BLAKE2B a5a5d3fee8301710ce36ba493e8b20c5ac5835f669cd35462bbe2390432b59e4ee38a8b5585cc8616fe11d646bfd4c4a2477b328584c526b4ed354e7b4ee7abf SHA512 0585c2f0b145875e9a13523d829b2ed9907e1e38c526f630a79a5b5dab36b6a9012375620ae92292e5977735c106bfab905bb121f56df5ca4494e1efcbd02cb6
+DIST File-RsyncP-0.76.tar.gz 167744 BLAKE2B e718a8cd18f3bf7c3d8b9ceb440c19b9544c232f2889532a15023ec1da6947085d4d07efb7edf7b1366830005f784e03b76bb9526d5ecb0072b3c0ab5fb88494 SHA512 b81d9ce63181605939e8aff87c9e56ab276899f019f44eb3f149e7ee0d44a94fcbee771381ebe6ca8281c2de0d57d9cbdbcb972ccb7406a0aefd920040603bb3