summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-09-10 11:57:09 +1200
committerKent Fredric <kentnl@gentoo.org>2020-09-11 03:02:12 +1200
commit8e1cf657aed74faa706d9fabc9b7a6290b8d9fc4 (patch)
tree2fd69fea2aa7c6a843f508fab404c67f37d464f2 /dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild
parentnet-misc/dropbox: add information on blocking autoupdate (diff)
downloadgentoo-8e1cf657aed74faa706d9fabc9b7a6290b8d9fc4.tar.gz
gentoo-8e1cf657aed74faa706d9fabc9b7a6290b8d9fc4.tar.bz2
gentoo-8e1cf657aed74faa706d9fabc9b7a6290b8d9fc4.zip
dev-perl/Filesys-SmbClient: -r bump for EAPI7 + misc toolchain love
- EAPI7 - Ensure CFLAGS passed to compiler - Rework the lib/inc handling stuff entirely, as the existing code still added its own "special" in injecting useless stuff like "/usr/lib/" into the libdir discovery, which caused linking to attempt to link 64bit code with 32bit code, before the real link. On GCC this doesn't fatal, but clang can..., so the whole thing is ripped out, the paths are hard-forced from ENV vars, and the pkgconfig magic is done in-ebuild instead of in Makefile.PL, making it less crazy, and also making it easier to change this later if its wrong. - Relocate configure.in to configure.ac to avoid an autotools.eclass AWOOOOOOOGA notice. Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild')
-rw-r--r--dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild b/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild
new file mode 100644
index 000000000000..adf20536a0e7
--- /dev/null
+++ b/dev-perl/Filesys-SmbClient/Filesys-SmbClient-3.200.0-r4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=ALIAN
+DIST_VERSION=3.2
+inherit perl-module autotools
+
+DESCRIPTION="Provide Perl API for libsmbclient.so"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=net-fs/samba-4.2[client]"
+DEPEND=">=net-fs/samba-4.2[client]"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/pkgconfig
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-close_fn.patch"
+ "${FILESDIR}/${PN}-3.2-no-magic-libdir.patch"
+)
+
+src_prepare() {
+ perl-module_src_prepare
+ cp -vf configure.in configure.ac || die "Can't copy configure.in"
+ perl_rm_files configure.in
+ eautoreconf
+}
+src_configure() {
+ GENTOO_INC_SMBCLIENT="$( pkg-config --variable=includedir smbclient )" \
+ GENTOO_LIB_SMBCLIENT="$( pkg-config --variable=libdir smbclient )" \
+ perl-module_src_configure
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+src_test() {
+ local MODULES=(
+ "Filesys::SmbClient ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ # standard tests are not designed to work on a non-developer system.
+}