summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/GD
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/GD')
-rw-r--r--dev-perl/GD/GD-2.460.0-r1.ebuild73
-rw-r--r--dev-perl/GD/GD-2.500.0-r1.ebuild73
-rw-r--r--dev-perl/GD/Manifest2
-rw-r--r--dev-perl/GD/metadata.xml16
4 files changed, 164 insertions, 0 deletions
diff --git a/dev-perl/GD/GD-2.460.0-r1.ebuild b/dev-perl/GD/GD-2.460.0-r1.ebuild
new file mode 100644
index 000000000000..fb99532a7a92
--- /dev/null
+++ b/dev-perl/GD/GD-2.460.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LDS
+MODULE_VERSION=2.46
+inherit perl-module
+
+DESCRIPTION="interface to Thomas Boutell's gd library"
+
+LICENSE="|| ( Artistic-2 GPL-1 GPL-2 GPL-3 )" # Artistic-2 or GPL1+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="animgif gif jpeg png truetype xpm"
+
+RDEPEND=">=media-libs/gd-2.0.33
+ png? (
+ media-libs/gd[png]
+ media-libs/libpng
+ sys-libs/zlib
+ )
+ jpeg? (
+ media-libs/gd[jpeg]
+ virtual/jpeg
+ )
+ truetype? (
+ media-libs/gd[truetype]
+ media-libs/freetype:2
+ )
+ xpm? (
+ media-libs/gd[xpm]
+ x11-libs/libXpm
+ )
+ gif? ( media-libs/giflib )"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=do
+
+src_prepare(){
+ perl-module_src_prepare
+ sed -i "s/use Getopt::Long;/use Getopt::Long qw(:config pass_through);/" \
+ "${S}"/Makefile.PL || die
+}
+
+src_configure() {
+ local myconf
+ use gif && use animgif && myconf+=",ANIMGIF"
+ use jpeg && myconf+=",JPEG"
+ use truetype && myconf+=",FREETYPE"
+ use png && myconf+=",PNG"
+ use xpm && myconf+=",XPM"
+ use gif && myconf+=",GIF"
+ myconf="-options '${myconf:1}'"
+ perl-module_src_configure
+}
+
+src_test() {
+ if use png || use jpeg || use gif ; then
+ if has_version ">=media-libs/jpeg-7" || \
+ has_version "media-libs/libjpeg-turbo" ; then
+ # https://rt.cpan.org/Public/Bug/Display.html?id=49053
+ ewarn "Tests fail with >=media-libs/jpeg-7 or media-libs/libjpeg-turbo. Skipping tests..."
+ return
+ fi
+ perl-module_src_test
+ else
+ ewarn "The test fails if neither of png, jpeg, gif is in USE!"
+ ewarn "Skipping tests..."
+ fi
+}
+mydoc="GD.html"
diff --git a/dev-perl/GD/GD-2.500.0-r1.ebuild b/dev-perl/GD/GD-2.500.0-r1.ebuild
new file mode 100644
index 000000000000..060eba3a8f41
--- /dev/null
+++ b/dev-perl/GD/GD-2.500.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LDS
+MODULE_VERSION=2.50
+inherit perl-module
+
+DESCRIPTION="interface to Thomas Boutell's gd library"
+
+LICENSE="|| ( Artistic-2 GPL-1 GPL-2 GPL-3 )" # Artistic-2 or GPL1+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="animgif gif jpeg png truetype xpm"
+
+RDEPEND=">=media-libs/gd-2.0.33
+ png? (
+ media-libs/gd[png]
+ media-libs/libpng
+ sys-libs/zlib
+ )
+ jpeg? (
+ media-libs/gd[jpeg]
+ virtual/jpeg
+ )
+ truetype? (
+ media-libs/gd[truetype]
+ media-libs/freetype:2
+ )
+ xpm? (
+ media-libs/gd[xpm]
+ x11-libs/libXpm
+ )
+ gif? ( media-libs/giflib )"
+DEPEND="${RDEPEND}"
+
+SRC_TEST=do
+
+src_prepare(){
+ perl-module_src_prepare
+ sed -i "s/use Getopt::Long;/use Getopt::Long qw(:config pass_through);/" \
+ "${S}"/Makefile.PL || die
+}
+
+src_configure() {
+ local myconf
+ use gif && use animgif && myconf+=",ANIMGIF"
+ use jpeg && myconf+=",JPEG"
+ use truetype && myconf+=",FREETYPE"
+ use png && myconf+=",PNG"
+ use xpm && myconf+=",XPM"
+ use gif && myconf+=",GIF"
+ myconf="-options '${myconf:1}'"
+ perl-module_src_configure
+}
+
+src_test() {
+ if use png || use jpeg || use gif ; then
+ if has_version ">=media-libs/jpeg-7" || \
+ has_version "media-libs/libjpeg-turbo" ; then
+ # https://rt.cpan.org/Public/Bug/Display.html?id=49053
+ ewarn "Tests fail with >=media-libs/jpeg-7 or media-libs/libjpeg-turbo. Skipping tests..."
+ return
+ fi
+ perl-module_src_test
+ else
+ ewarn "The test fails if neither of png, jpeg, gif is in USE!"
+ ewarn "Skipping tests..."
+ fi
+}
+mydoc="GD.html"
diff --git a/dev-perl/GD/Manifest b/dev-perl/GD/Manifest
new file mode 100644
index 000000000000..2ca25819c264
--- /dev/null
+++ b/dev-perl/GD/Manifest
@@ -0,0 +1,2 @@
+DIST GD-2.46.tar.gz 260989 SHA256 0de778c8ea63bb3eb0d99d0ef090464ef594107addfa71750fd3a88216081735 SHA512 804f7c7b7d6ba517a18be13d9d51d382e3770b965512a337281335a2f9985320e194e57dcd82b94b690f9438249a5cc9830bff4cdb0c2aad0c99153ad3d92e34 WHIRLPOOL 035d8b3486ea44b991912f42a6eb9228a76619fca2da6b15ea3221eead5aa30205ae5ca156aeff674a5564c5f9181b516499e2462771e5cd3953adc1d8e0ac70
+DIST GD-2.50.tar.gz 262887 SHA256 6d5392d067a48dd66d67e65b1bfab7a8e6e149490eabfa09f70b99223ea0a8e2 SHA512 d32074d6d988ab8b1dd0283bdec2baf3dfc61141d8c23f300592990fd3b42ce98b545dc3339f7df582750231023b02c98fe0271de37f05e5b64ad2d4da00b096 WHIRLPOOL 63d41e8df861967f13f42964eff6481a053630613a9bbe2d4365913b68f61eeefc220469556063e985fddb7d6c680af7321cef97717e15ab3ea55db87723e25d
diff --git a/dev-perl/GD/metadata.xml b/dev-perl/GD/metadata.xml
new file mode 100644
index 000000000000..ee4d2129fc42
--- /dev/null
+++ b/dev-perl/GD/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <use>
+ <flag name="animgif">Enable animated gif support</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">GD</remote-id>
+ <remote-id type="cpan-module">GD</remote-id>
+ <remote-id type="cpan-module">GD::Group</remote-id>
+ <remote-id type="cpan-module">GD::Polygon</remote-id>
+ <remote-id type="cpan-module">GD::Polyline</remote-id>
+ <remote-id type="cpan-module">GD::Simple</remote-id>
+ </upstream>
+</pkgmetadata>