summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-09-01 18:58:23 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-09-01 18:58:23 +0200
commitccde7f0195a1a3b7959941fb950d92ae9d9880a3 (patch)
tree4ea3f420a29f65fc4f95cbdd1b54ce90d4154617 /dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.103.0.ebuild
parentapp-emulation/wine-any: Sync with ::wine (diff)
downloadgentoo-ccde7f0195a1a3b7959941fb950d92ae9d9880a3.tar.gz
gentoo-ccde7f0195a1a3b7959941fb950d92ae9d9880a3.tar.bz2
gentoo-ccde7f0195a1a3b7959941fb950d92ae9d9880a3.zip
dev-perl/Getopt-Long-Descriptive: Version bump
Bug: https://bugs.gentoo.org/661200 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.103.0.ebuild')
-rw-r--r--dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.103.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.103.0.ebuild b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.103.0.ebuild
new file mode 100644
index 000000000000..a3cb53187d6a
--- /dev/null
+++ b/dev-perl/Getopt-Long-Descriptive/Getopt-Long-Descriptive-0.103.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.103
+inherit perl-module
+
+DESCRIPTION="Getopt::Long with usage text"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test minimal"
+
+CONFLICTS="!<dev-perl/MooseX-Getopt-0.660.0"
+# File::Basename -> perl
+# List::Util, Scalar::Util -> perl-Scalar-List-Utils
+# Sub::Exporter::Util -> Sub-Exporter
+RDEPEND="${CONFLICTS}
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.330.0
+ >=dev-perl/Params-Validate-0.970.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Sub-Exporter-0.972.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 )
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ >=dev-perl/Test-Warnings-0.5.0
+ )
+"