summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-04 05:25:38 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-04 05:26:06 +1300
commit36438d4838240ab77b4750658dd832148450596f (patch)
tree990634bd2802689a4cd7c5998a941b18a743dadd /dev-perl/Git-Wrapper
parentsys-libs/glibc: Revision bump for a much larger patchset 2 (diff)
downloadgentoo-36438d4838240ab77b4750658dd832148450596f.tar.gz
gentoo-36438d4838240ab77b4750658dd832148450596f.tar.bz2
gentoo-36438d4838240ab77b4750658dd832148450596f.zip
dev-perl/Git-Wrapper: Fix missing dep on dev-vcs/git bug #633384
Also adds a late src_compile test that asserts Git::Wrapper is loadable, and will fail if src_prepare fails silently like it did in bug #633384 due to the absence of `blib`. Closes: https://bugs.gentoo.org/633384 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Git-Wrapper')
-rw-r--r--dev-perl/Git-Wrapper/Git-Wrapper-0.47.0-r1.ebuild (renamed from dev-perl/Git-Wrapper/Git-Wrapper-0.47.0.ebuild)11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-perl/Git-Wrapper/Git-Wrapper-0.47.0.ebuild b/dev-perl/Git-Wrapper/Git-Wrapper-0.47.0-r1.ebuild
index c6964a0471f4..bc2693e5b6e6 100644
--- a/dev-perl/Git-Wrapper/Git-Wrapper-0.47.0.ebuild
+++ b/dev-perl/Git-Wrapper/Git-Wrapper-0.47.0-r1.ebuild
@@ -14,6 +14,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND="
+ dev-vcs/git
virtual/perl-File-Temp
dev-perl/File-chdir
virtual/perl-IPC-Cmd
@@ -34,3 +35,13 @@ DEPEND="${RDEPEND}
virtual/perl-Test-Simple
)
"
+src_compile() {
+ perl-module_src_compile
+ local MODULES=(
+ "Git::Wrapper ${DIST_VERSION}"
+ )
+ for dep in "${MODULES[@]}"; do
+ perl -Mblib="${S}" -M"${dep} ()" -e1 ||
+ die "Could not load ${dep}"
+ done
+}