summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-27 07:13:21 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-27 07:51:48 +1300
commit345e9497960ae251cafbd83d7c7eff39a4922b7f (patch)
treea4a42d7bcbe9bfd5233d1b4b3364758701ca668c /dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.42.0.ebuild
parentdev-perl/DBD-SQLite: Bump to version 1.540.0 (diff)
downloadgentoo-345e9497960ae251cafbd83d7c7eff39a4922b7f.tar.gz
gentoo-345e9497960ae251cafbd83d7c7eff39a4922b7f.tar.bz2
gentoo-345e9497960ae251cafbd83d7c7eff39a4922b7f.zip
dev-perl/Glib-Object-Introspection: Bump to version 0.42.0
Upstream: - Add fixes for newer EUMM - Prefer stack over heap when marshalling - Use custom code for struct methods to avoid bugs - Add support for object class functions - Add support for marshalling GParamSpec - Add GValueWrapper::get_value - perli11ndoc greatly improved structures. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.42.0.ebuild')
-rw-r--r--dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.42.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.42.0.ebuild b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.42.0.ebuild
new file mode 100644
index 000000000000..d7146e58227c
--- /dev/null
+++ b/dev-perl/Glib-Object-Introspection/Glib-Object-Introspection-0.42.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=XAOC
+DIST_VERSION=0.042
+inherit perl-module xdg-utils
+
+DESCRIPTION="Dynamically create Perl language bindings"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/glib-perl-1.320.0
+ >=dev-libs/gobject-introspection-1.0
+ >=dev-libs/libffi-3.0.0
+ >=dev-libs/glib-2.0.0
+"
+DEPEND="
+ >=dev-perl/ExtUtils-Depends-0.300.0
+ >=dev-perl/ExtUtils-PkgConfig-1.0.0
+ ${RDEPEND}
+"
+
+pkg_setup() {
+ xdg_environment_reset # bug #599128
+}