summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/GraphViz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/GraphViz')
-rw-r--r--dev-perl/GraphViz/GraphViz-2.140.0.ebuild38
-rw-r--r--dev-perl/GraphViz/GraphViz-2.180.0.ebuild49
-rw-r--r--dev-perl/GraphViz/Manifest2
-rw-r--r--dev-perl/GraphViz/metadata.xml18
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-perl/GraphViz/GraphViz-2.140.0.ebuild b/dev-perl/GraphViz/GraphViz-2.140.0.ebuild
new file mode 100644
index 000000000000..e2d36965ab99
--- /dev/null
+++ b/dev-perl/GraphViz/GraphViz-2.140.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_A_EXT=tgz
+MODULE_AUTHOR=RSAVAGE
+MODULE_VERSION=2.14
+inherit perl-module
+
+DESCRIPTION="GraphViz - Interface to the GraphViz graphing tool"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="
+ media-gfx/graphviz
+ dev-perl/IPC-Run
+"
+ #dev-perl/XML-Twig
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ >=dev-perl/Test-Pod-1.440.0
+ )
+"
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*
+}
diff --git a/dev-perl/GraphViz/GraphViz-2.180.0.ebuild b/dev-perl/GraphViz/GraphViz-2.180.0.ebuild
new file mode 100644
index 000000000000..646e3bcbb556
--- /dev/null
+++ b/dev-perl/GraphViz/GraphViz-2.180.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_A_EXT=tgz
+MODULE_AUTHOR=RSAVAGE
+MODULE_VERSION=2.18
+inherit perl-module
+
+DESCRIPTION="GraphViz - Interface to the GraphViz graphing tool"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ media-gfx/graphviz
+ virtual/perl-Carp
+ >=virtual/perl-Getopt-Long-2.340.0
+ virtual/perl-IO
+ >=dev-perl/IPC-Run-0.600.0
+ >=dev-perl/libwww-perl-6
+ >=dev-perl/Parse-RecDescent-1.965.1
+ >=virtual/perl-Time-HiRes-1.510.0
+ >=dev-perl/XML-Twig-3.380.0
+ >=dev-perl/XML-XPath-1.130.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.421.100
+ >=dev-perl/File-Which-1.90.0
+ test? (
+ >=dev-perl/Test-Pod-1.480.0
+ )
+"
+
+# tests need
+# >=virtual/perl-Test-Simple-1.1.14
+# therefore temporarily disable
+# SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*
+}
diff --git a/dev-perl/GraphViz/Manifest b/dev-perl/GraphViz/Manifest
new file mode 100644
index 000000000000..b9fa02ab4f4b
--- /dev/null
+++ b/dev-perl/GraphViz/Manifest
@@ -0,0 +1,2 @@
+DIST GraphViz-2.14.tgz 117648 SHA256 9958e697ada73f47a7e4e6529181f5d74ad3e212716c18123053cb4a085cf2e0 SHA512 f0a9c14dcb4456fd426e6c8adaa2757a057800fad8022f9f6e43b275b9cc8b4a31319e83bf659b4d0d608e400caa3268fb884fc7db437f068d2b96111a5c134e WHIRLPOOL 3eb94070fa829c9893431a6258009d2323e0db372036f68a56dd40e69dc4077330db7ef65dc948adf62887e181eeac4d9be60980048eb281b9d01ed773f3b10b
+DIST GraphViz-2.18.tgz 115211 SHA256 305d012a43e9522d5f91b63a52e926061ba372431735ede95ce7712f486baffd SHA512 4c0171a6c404efcacb4807983170ad13d53109b58378410955afff94fa13c679bad74ed5a0ac8b13ac62975eb723c6e53f0a96526f7319364aa4c798e6a71c1c WHIRLPOOL b9df737a654688948db6b63d09ce380b878df6bc06462518bea56af3c982b24f06ffd23df769be3f8715b87e29f700a0af27c432a3389e6f1b144e2ceea8d496
diff --git a/dev-perl/GraphViz/metadata.xml b/dev-perl/GraphViz/metadata.xml
new file mode 100644
index 000000000000..2e8626388d09
--- /dev/null
+++ b/dev-perl/GraphViz/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">GraphViz</remote-id>
+ <remote-id type="cpan-module">Devel::GraphVizProf</remote-id>
+ <remote-id type="cpan-module">GraphViz</remote-id>
+ <remote-id type="cpan-module">GraphViz::Data::Grapher</remote-id>
+ <remote-id type="cpan-module">GraphViz::No</remote-id>
+ <remote-id type="cpan-module">GraphViz::Parse::RecDescent</remote-id>
+ <remote-id type="cpan-module">GraphViz::Parse::Yacc</remote-id>
+ <remote-id type="cpan-module">GraphViz::Parse::Yapp</remote-id>
+ <remote-id type="cpan-module">GraphViz::Regex</remote-id>
+ <remote-id type="cpan-module">GraphViz::Small</remote-id>
+ <remote-id type="cpan-module">GraphViz::XML</remote-id>
+ </upstream>
+</pkgmetadata>