summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-04-20 14:51:21 +0200
committerEttore Di Giacinto <mudler@gentoo.org>2017-04-20 14:56:35 +0200
commit5b068a3cde897f7575f958d5a23653172f8d5008 (patch)
tree74c141653daf49889a5a78ab8941bf54120f8e33 /dev-perl/HTML-Tree/HTML-Tree-5.40.0.ebuild
parentnet-analyzer/cacti-spine: Version bump. (diff)
downloadgentoo-5b068a3cde897f7575f958d5a23653172f8d5008.tar.gz
gentoo-5b068a3cde897f7575f958d5a23653172f8d5008.tar.bz2
gentoo-5b068a3cde897f7575f958d5a23653172f8d5008.zip
dev-perl/HTML-Tree: bump version to 5.40.0 wrt bug #614800
Upstream changes: - Remove Distzilla (fixes '.' in @INC) - Add POD to htmltree - Speed up is_inside method - Fix extra spaces being added to comments - Don't needlessly escape characters in element content Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=614800 Package-Manager: Portage-2.3.3, Repoman-2.3.2
Diffstat (limited to 'dev-perl/HTML-Tree/HTML-Tree-5.40.0.ebuild')
-rw-r--r--dev-perl/HTML-Tree/HTML-Tree-5.40.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/HTML-Tree/HTML-Tree-5.40.0.ebuild b/dev-perl/HTML-Tree/HTML-Tree-5.40.0.ebuild
new file mode 100644
index 000000000000..bbc276e3bc58
--- /dev/null
+++ b/dev-perl/HTML-Tree/HTML-Tree-5.40.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=JFEARN
+MODULE_VERSION=5.04
+inherit perl-module
+
+DESCRIPTION="A library to manage HTML-Tree in PERL"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/HTML-Tagset-3.03
+ >=dev-perl/HTML-Parser-3.46
+"
+# dev-perl/HTML-Format
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Test-Fatal
+ )
+"
+
+SRC_TEST="do"