summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-08 13:50:14 +1200
committerKent Fredric <kentnl@gentoo.org>2017-04-08 13:50:14 +1200
commita6618650461eb26dfe3a969ff6e9ae4ab2123a67 (patch)
tree55bd18f4865b04a178759aed53cf230fa7b17dba /dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0.ebuild
parentdev-perl/DateTime-Format-W3CDTF: Bump to version 0.70.0 (diff)
downloadgentoo-a6618650461eb26dfe3a969ff6e9ae4ab2123a67.tar.gz
gentoo-a6618650461eb26dfe3a969ff6e9ae4ab2123a67.tar.bz2
gentoo-a6618650461eb26dfe3a969ff6e9ae4ab2123a67.zip
dev-perl/HTTP-Cache-Transparent: Bump to version 1.400.0
- EAPI6 - Add USE="examples" - Parallel Testing Upstream: - Add X-No-Server-Contact header Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0.ebuild')
-rw-r--r--dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0.ebuild b/dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0.ebuild
new file mode 100644
index 000000000000..81ccf97a1a87
--- /dev/null
+++ b/dev-perl/HTTP-Cache-Transparent/HTTP-Cache-Transparent-1.400.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MATTIASH
+DIST_VERSION=1.4
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Cache the result of http get-requests persistently"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/libwww-perl
+ virtual/perl-Digest-MD5
+ virtual/perl-Storable"
+DEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Simple )"
+
+src_test() {
+ perl_rm_files t/pod.t t/pod-coverage.t
+ perl-module_src_test
+}