summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-04-02 00:20:22 +1300
committerKent Fredric <kentnl@gentoo.org>2017-04-02 00:20:51 +1300
commite458ad1ce98af9aa79a2180d1258dde4d67a88cb (patch)
tree828bec9c413d66085cc523d1fb20a86fd30a0e6a /dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.520.0.ebuild
parentmedia-libs/libbluray: drop empty keyword lines. (diff)
downloadgentoo-e458ad1ce98af9aa79a2180d1258dde4d67a88cb.tar.gz
gentoo-e458ad1ce98af9aa79a2180d1258dde4d67a88cb.tar.bz2
gentoo-e458ad1ce98af9aa79a2180d1258dde4d67a88cb.zip
dev-perl/HTTP-Server-Simple: Bump to version 0.520.0
Upstream: - Fix for '.' in @INC Bug: https://bugs.gentoo.org/614414 Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.520.0.ebuild')
-rw-r--r--dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.520.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.520.0.ebuild b/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.520.0.ebuild
new file mode 100644
index 000000000000..2d77c985c956
--- /dev/null
+++ b/dev-perl/HTTP-Server-Simple/HTTP-Server-Simple-0.520.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BPS
+DIST_VERSION=0.52
+inherit perl-module
+
+DESCRIPTION="Lightweight HTTP Server"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/CGI
+ >=virtual/perl-Socket-1.940.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_test() {
+ perl_rm_files t/02pod.t t/03podcoverage.t
+ perl-module_src_test
+}