summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-02 23:45:07 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-03 00:23:42 +1200
commitc4832e0334d890572eade4bbe88aa8d1d7d4a655 (patch)
treeb0a536ebd8eccc55c9f309f60a989ee211329b2c /dev-perl/Hash-FieldHash
parentapp-text/pdfarranger: clean old (diff)
downloadgentoo-c4832e0334d890572eade4bbe88aa8d1d7d4a655.tar.gz
gentoo-c4832e0334d890572eade4bbe88aa8d1d7d4a655.tar.bz2
gentoo-c4832e0334d890572eade4bbe88aa8d1d7d4a655.zip
dev-perl/Hash-FieldHash: -r bump for EAPI7 + tooling fixes
- EAPI7 - Migrate sed hack to "patch" - Prevent LD="ld" breaking the build - Ensure CFLAGS passed through to cc Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Hash-FieldHash')
-rw-r--r--dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild46
-rw-r--r--dev-perl/Hash-FieldHash/files/Hash-FieldHash-0.15-no-dot-inc.patch26
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild b/dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild
new file mode 100644
index 000000000000..7925730085d0
--- /dev/null
+++ b/dev-perl/Hash-FieldHash/Hash-FieldHash-0.150.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=GFUJI
+DIST_VERSION=0.15
+DIST_EXAMPLES=( "example/*" "benchmark" )
+inherit perl-module
+
+DESCRIPTION="Lightweight field hash for inside-out objects"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-XSLoader-0.20.0
+ >=virtual/perl-parent-0.221.0
+"
+DEPEND="
+ dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-Devel-PPPort-3.190.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-2.210.0
+ >=dev-perl/Module-Build-0.400.500
+ test? (
+ >=dev-perl/Test-LeakTrace-0.70.0
+ >=virtual/perl-Test-Simple-0.620.0
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.15-no-dot-inc.patch"
+)
+src_configure() {
+ unset LD;
+ if [[ -n "${CCLD}" ]]; then
+ export LD="${CCLD}"
+ fi
+ perl-module_src_configure
+}
+src_compile() {
+ ./Build --config optimize="${CFLAGS}" build || die
+}
diff --git a/dev-perl/Hash-FieldHash/files/Hash-FieldHash-0.15-no-dot-inc.patch b/dev-perl/Hash-FieldHash/files/Hash-FieldHash-0.15-no-dot-inc.patch
new file mode 100644
index 000000000000..95ae110c028b
--- /dev/null
+++ b/dev-perl/Hash-FieldHash/files/Hash-FieldHash-0.15-no-dot-inc.patch
@@ -0,0 +1,26 @@
+From c4f929a44ace9ef304b270862c81acc07e273f63 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 2 Jul 2020 23:19:50 +1200
+Subject: Include '.' in @INC for perl 5.26+
+
+Bug: https://github.com/gfx/p5-Hash-FieldHash/issues/4
+---
+ Build.PL | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Build.PL b/Build.PL
+index 8ba2832..cb7f572 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -8,7 +8,7 @@ use 5.008_001;
+ use strict;
+ use warnings;
+ use utf8;
+-
++use lib '.';
+ use builder::MyBuilder;
+ use File::Basename;
+ use File::Spec;
+--
+2.27.0
+