summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-26 13:42:05 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-26 13:42:21 +1300
commit48dcf0b8310d2e7ed8579d1b8d8857e9e881d8c6 (patch)
treeef0afcca9c2285c99603b85fccee97c48040f856 /dev-perl/IMAP-Admin/IMAP-Admin-1.6.8.ebuild
parentmedia-plugins/caps-plugins: Stable on amd64 (diff)
downloadgentoo-48dcf0b8310d2e7ed8579d1b8d8857e9e881d8c6.tar.gz
gentoo-48dcf0b8310d2e7ed8579d1b8d8857e9e881d8c6.tar.bz2
gentoo-48dcf0b8310d2e7ed8579d1b8d8857e9e881d8c6.zip
dev-perl/IMAP-Admin: Bump to version 1.6.8
- EAPI6 - Add basic compile tests - Fence/document manual tests Upstream: - Remove use of legacy defined(@array) syntax Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/IMAP-Admin/IMAP-Admin-1.6.8.ebuild')
-rw-r--r--dev-perl/IMAP-Admin/IMAP-Admin-1.6.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/IMAP-Admin/IMAP-Admin-1.6.8.ebuild b/dev-perl/IMAP-Admin/IMAP-Admin-1.6.8.ebuild
new file mode 100644
index 000000000000..0aa8613b1af4
--- /dev/null
+++ b/dev-perl/IMAP-Admin/IMAP-Admin-1.6.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=EESTABROO
+DIST_EXAMPLES=("examples/*" "test.pl")
+inherit perl-module
+
+DESCRIPTION="Perl module for basic IMAP server administration"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_test() {
+ local MODULES=(
+ "IMAP::Admin ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ ewarn "Comprehensive testing requires manual steps. For details, see:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+}