summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-26 15:00:13 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-26 15:00:34 +1300
commit17f7bd89b2e2a95c27e4500e245ebaf9cd96f979 (patch)
treed07681b60010c003630e092bfbda2ae3b41eee67 /dev-perl/IO-AIO/IO-AIO-4.340.0.ebuild
parentsys-apps/rng-tools: add support for NP_TPM and NO_DRNG options in v6 (diff)
downloadgentoo-17f7bd89b2e2a95c27e4500e245ebaf9cd96f979.tar.gz
gentoo-17f7bd89b2e2a95c27e4500e245ebaf9cd96f979.tar.bz2
gentoo-17f7bd89b2e2a95c27e4500e245ebaf9cd96f979.zip
dev-perl/IO-AIO: Bump to version 4.340.0
- Enable previously disabled tests - Fence unrunnable tests Upstream: - Fix missing def0.h - Fix major/minor switching - remove duplicate definition of MAP_HUGETLB - Add aio_fcntl and aio_ioctl - Names set via prctl are truncated to 15 chars + null, not 16 chars Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/IO-AIO/IO-AIO-4.340.0.ebuild')
-rw-r--r--dev-perl/IO-AIO/IO-AIO-4.340.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/IO-AIO/IO-AIO-4.340.0.ebuild b/dev-perl/IO-AIO/IO-AIO-4.340.0.ebuild
new file mode 100644
index 000000000000..0d1a730a6890
--- /dev/null
+++ b/dev-perl/IO-AIO/IO-AIO-4.340.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=4.34
+inherit perl-module
+
+DESCRIPTION="Asynchronous Input/Output"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+#RESTRICT="test"
+
+RDEPEND="dev-perl/common-sense"
+DEPEND="${RDEPEND}
+ >=dev-perl/Canary-Stability-2001
+ >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+"
+src_test() {
+ if [[ "${IO_AIO_SANDBOX_TESTS:-0}" == 0 ]]; then
+ # Tests trigger stack overflow in sandbox code, see bug 553918
+ perl_rm_files t/01_stat.t t/02_read.t t/05_readdir.t t/03_errors.t
+ ewarn "Some tests cannot be run under a sandbox. For details, see:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+ fi
+ perl-module_src_test
+}