summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-26 17:22:02 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-26 17:32:54 +1300
commit86045d2fbe58272b54892e1cdf46ced83e1f45a4 (patch)
treef1a96b52e4aae80baefcd82195bff44b54403a6a /dev-perl/IO-Socket-INET6
parentdev-perl/IO-SessionData: EAPI6 (diff)
downloadgentoo-86045d2fbe58272b54892e1cdf46ced83e1f45a4.tar.gz
gentoo-86045d2fbe58272b54892e1cdf46ced83e1f45a4.tar.bz2
gentoo-86045d2fbe58272b54892e1cdf46ced83e1f45a4.zip
dev-perl/IO-Socket-INET6: Restore tests
- EAPI6 - Enable tests If these tests are still failing for people, open a new bug and we can try work out which sub-set we *can* run and which we cant, instead of just disabling tests globally, which helps nobody. Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/IO-Socket-INET6')
-rw-r--r--dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild b/dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild
new file mode 100644
index 000000000000..3f3607ad9cfb
--- /dev/null
+++ b/dev-perl/IO-Socket-INET6/IO-Socket-INET6-2.720.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.72
+inherit perl-module
+
+DESCRIPTION="Work with IO sockets in ipv6"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="dev-perl/Socket6"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build"
+
+src_test() {
+ local BADTESTS=(
+ t/pod-coverage.t
+ t/pod.t
+ t/style-trailing-space.t
+ )
+ perl_rm_files "${BADTESTS[@]}"
+ perl-module_src_test
+}