summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-22 11:04:59 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-22 11:05:18 +1200
commit52123fe492e16f3a64c47b9b854990591258062f (patch)
tree3d80189da5e7749bdde0062ee8eade9ab05f792c /dev-perl/IO-Socket-SSL/IO-Socket-SSL-2.48.0.ebuild
parentvirtual/podofo-build: add tools USE flag (bug 608876) (diff)
downloadgentoo-52123fe492e16f3a64c47b9b854990591258062f.tar.gz
gentoo-52123fe492e16f3a64c47b9b854990591258062f.tar.bz2
gentoo-52123fe492e16f3a64c47b9b854990591258062f.zip
dev-perl/IO-Socket-SSL: Bump to version 2.48.0
Upstream: - Fix memory leaks in socket/context destruction Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/IO-Socket-SSL/IO-Socket-SSL-2.48.0.ebuild')
-rw-r--r--dev-perl/IO-Socket-SSL/IO-Socket-SSL-2.48.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/IO-Socket-SSL/IO-Socket-SSL-2.48.0.ebuild b/dev-perl/IO-Socket-SSL/IO-Socket-SSL-2.48.0.ebuild
new file mode 100644
index 000000000000..f3881ea2cc7d
--- /dev/null
+++ b/dev-perl/IO-Socket-SSL/IO-Socket-SSL-2.48.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SULLR
+DIST_VERSION=2.048
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Nearly transparent SSL encapsulation for IO::Socket::INET"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="idn"
+
+RDEPEND="
+ >=dev-perl/Net-SSLeay-1.460.0
+ virtual/perl-Scalar-List-Utils
+ idn? (
+ || (
+ >=dev-perl/URI-1.50
+ dev-perl/Net-LibIDN
+ dev-perl/Net-IDN-Encode
+ )
+ )"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+mydoc=("docs/debugging.txt")