summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-31 14:44:13 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-31 14:44:31 +1200
commitd0fd10a7808de1f33dc2e9ea7f5c96d978fd11d1 (patch)
treeb92f2e9c7f67804f70b587cc96b0b50b986d2396 /dev-perl/Inline-C/Inline-C-0.780.0.ebuild
parentnet-wireless/chirp: bump (diff)
downloadgentoo-d0fd10a7808de1f33dc2e9ea7f5c96d978fd11d1.tar.gz
gentoo-d0fd10a7808de1f33dc2e9ea7f5c96d978fd11d1.tar.bz2
gentoo-d0fd10a7808de1f33dc2e9ea7f5c96d978fd11d1.zip
dev-perl/Inline-C: Bump to version 0.780.0 re bug #617002
- Add USE="examples" Upstream: - Remove systemcalls "rm" and "diff" - Fixes for "." in "@INC" Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Inline-C/Inline-C-0.780.0.ebuild')
-rw-r--r--dev-perl/Inline-C/Inline-C-0.780.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/Inline-C/Inline-C-0.780.0.ebuild b/dev-perl/Inline-C/Inline-C-0.780.0.ebuild
new file mode 100644
index 000000000000..4687679c5424
--- /dev/null
+++ b/dev-perl/Inline-C/Inline-C-0.780.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TINITA
+DIST_VERSION=0.78
+DIST_EXAMPLES=("example/modules/*")
+inherit perl-module
+
+DESCRIPTION="C Language Support for Inline"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DIST_TEST="do" # parallelism thwarted by race conditions
+
+RDEPEND="
+ >=virtual/perl-ExtUtils-MakeMaker-7
+ >=virtual/perl-File-Spec-0.800.0
+ >=dev-perl/Inline-0.790.0
+ >=dev-perl/Parse-RecDescent-1.967.9
+ >=dev-perl/Pegex-0.580.0
+ !<dev-perl/Inline-0.510.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/File-ShareDir-Install-0.60.0
+ test? (
+ dev-perl/File-Copy-Recursive
+ virtual/perl-File-Path
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-Warn-0.230.0
+ dev-perl/YAML-LibYAML
+ virtual/perl-autodie
+ >=virtual/perl-version-0.770.0
+ )
+"
+src_test() {
+ perl_rm_files t/author-*.t
+ perl-module_src_test
+}