summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/List-AllUtils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/List-AllUtils')
-rw-r--r--dev-perl/List-AllUtils/List-AllUtils-0.30.0-r1.ebuild23
-rw-r--r--dev-perl/List-AllUtils/List-AllUtils-0.80.0.ebuild27
-rw-r--r--dev-perl/List-AllUtils/List-AllUtils-0.90.0.ebuild27
-rw-r--r--dev-perl/List-AllUtils/Manifest2
-rw-r--r--dev-perl/List-AllUtils/metadata.xml9
5 files changed, 88 insertions, 0 deletions
diff --git a/dev-perl/List-AllUtils/List-AllUtils-0.30.0-r1.ebuild b/dev-perl/List-AllUtils/List-AllUtils-0.30.0-r1.ebuild
new file mode 100644
index 000000000000..32fff3f551b9
--- /dev/null
+++ b/dev-perl/List-AllUtils/List-AllUtils-0.30.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.03
+inherit perl-module
+
+DESCRIPTION='Combines List::Util and List::MoreUtils in one bite-sized package'
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/List-MoreUtils-0.280.0
+ >=virtual/perl-Scalar-List-Utils-1.190.0
+"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/List-AllUtils/List-AllUtils-0.80.0.ebuild b/dev-perl/List-AllUtils/List-AllUtils-0.80.0.ebuild
new file mode 100644
index 000000000000..6d28df716246
--- /dev/null
+++ b/dev-perl/List-AllUtils/List-AllUtils-0.80.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION='Combines List::Util and List::MoreUtils in one bite-sized package'
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-perl/List-MoreUtils-0.280.0
+ >=virtual/perl-Scalar-List-Utils-1.310.0"
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Warnings )"
+
+SRC_TEST="do"
diff --git a/dev-perl/List-AllUtils/List-AllUtils-0.90.0.ebuild b/dev-perl/List-AllUtils/List-AllUtils-0.90.0.ebuild
new file mode 100644
index 000000000000..ac415b77959f
--- /dev/null
+++ b/dev-perl/List-AllUtils/List-AllUtils-0.90.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION='Combines List::Util and List::MoreUtils in one bite-sized package'
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-perl/List-MoreUtils-0.280.0
+ >=virtual/perl-Scalar-List-Utils-1.310.0"
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-File-Temp
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Warnings )"
+
+SRC_TEST="do"
diff --git a/dev-perl/List-AllUtils/Manifest b/dev-perl/List-AllUtils/Manifest
new file mode 100644
index 000000000000..09ba3eb7f43f
--- /dev/null
+++ b/dev-perl/List-AllUtils/Manifest
@@ -0,0 +1,2 @@
+DIST List-AllUtils-0.03.tar.gz 14355 SHA256 4806cc718c5b7530d0bec48d3f7682e7f55a489be4014519d68f937c11c2a115 SHA512 b2b9165df393d8c8e9f19ab46aa6ede0c5b80eda59fd6800932ee342d34f20ee9ef7ae89f78f90c31131fe4352800eb93b6e631bce9adf2e4aa41730d6e8a98f WHIRLPOOL 32bcf02fa4ac198c46f852553c74d97dc5f38b5d0988386d4060c1452519cc01bd81f86adec35405e974385ec05fcd86bf0d52474039a2ca2ad608f9c9d475e2
+DIST List-AllUtils-0.08.tar.gz 19283 SHA256 27ddc2f0d47656cd3e08846ffe19f765bbd6c1d0e3c751ce4bb704e2b0b7ad1f SHA512 112591ad2c0ecfdbe2757e96827d5ea8f6d2b47491ace9ba406270fb6d15626a28da2381ef27231c61b7b4b42dc1bdeb323defa751d9a5cd20ca2cf489cd28e3 WHIRLPOOL e8191107c7f1a7beaf43e08fabd84ace25c4a6b5859e1eefb8c0b4a378abcf3620f2c0fd15f3b2a412dc5a9d757f6d905b2e849461e5d833662eb3cdc13d91a5
diff --git a/dev-perl/List-AllUtils/metadata.xml b/dev-perl/List-AllUtils/metadata.xml
new file mode 100644
index 000000000000..b2adbd6c1080
--- /dev/null
+++ b/dev-perl/List-AllUtils/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">List-AllUtils</remote-id>
+ <remote-id type="cpan-module">List::AllUtils</remote-id>
+ </upstream>
+</pkgmetadata>