summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-28 17:03:18 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-29 12:54:21 +1300
commit91ddb160174ce370fb39765845a545935a64fcb0 (patch)
tree3b03bfb4e8454125576ac6272fbbbd71b76304b2 /dev-perl/Log-Any/Log-Any-1.701.0.ebuild
parentdev-perl/List-SomeUtils: Bump to version 0.560.0 (diff)
downloadgentoo-91ddb160174ce370fb39765845a545935a64fcb0.tar.gz
gentoo-91ddb160174ce370fb39765845a545935a64fcb0.tar.bz2
gentoo-91ddb160174ce370fb39765845a545935a64fcb0.zip
dev-perl/Log-Any: Bump to version 1.701.0
Upstream: - Add structured logging to log hashrefs in parseable format - Add contextual logging support for context tagging - LOG_ANY_DEFAULT_ADAPTER now logs to the given adapter instead of Null - Fix method aliases ::Syslog that were mapped to wrong/invalid priorities Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Log-Any/Log-Any-1.701.0.ebuild')
-rw-r--r--dev-perl/Log-Any/Log-Any-1.701.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Log-Any/Log-Any-1.701.0.ebuild b/dev-perl/Log-Any/Log-Any-1.701.0.ebuild
new file mode 100644
index 000000000000..cc5823ce8177
--- /dev/null
+++ b/dev-perl/Log-Any/Log-Any-1.701.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PREACTION
+DIST_VERSION=1.701
+inherit perl-module
+
+DESCRIPTION="Bringing loggers and listeners together"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test minimal"
+
+# Test::Builder needed for Log/Any/Adapter/Test.pm
+# constant -> perl
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Data-Dumper
+ virtual/perl-Exporter
+ virtual/perl-IO
+ virtual/perl-Storable
+ virtual/perl-Sys-Syslog
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? ( >=virtual/perl-CPAN-Meta-2.120.900 )
+ virtual/perl-File-Spec
+ )
+"