summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/MARC-Record
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/MARC-Record')
-rw-r--r--dev-perl/MARC-Record/MARC-Record-2.0.5.ebuild22
-rw-r--r--dev-perl/MARC-Record/MARC-Record-2.0.6.ebuild29
-rw-r--r--dev-perl/MARC-Record/Manifest2
-rw-r--r--dev-perl/MARC-Record/metadata.xml15
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/MARC-Record/MARC-Record-2.0.5.ebuild b/dev-perl/MARC-Record/MARC-Record-2.0.5.ebuild
new file mode 100644
index 000000000000..ea0cd240315c
--- /dev/null
+++ b/dev-perl/MARC-Record/MARC-Record-2.0.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GMCHARLT
+MODULE_VERSION=2.0.5
+inherit perl-module
+
+DESCRIPTION="MARC manipulation (library bibliographic)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST=do
diff --git a/dev-perl/MARC-Record/MARC-Record-2.0.6.ebuild b/dev-perl/MARC-Record/MARC-Record-2.0.6.ebuild
new file mode 100644
index 000000000000..130cd984027f
--- /dev/null
+++ b/dev-perl/MARC-Record/MARC-Record-2.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GMCHARLT
+inherit perl-module
+
+DESCRIPTION="Perl extension for handling MARC records"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/MARC-Record/Manifest b/dev-perl/MARC-Record/Manifest
new file mode 100644
index 000000000000..1a90b8e0305b
--- /dev/null
+++ b/dev-perl/MARC-Record/Manifest
@@ -0,0 +1,2 @@
+DIST MARC-Record-2.0.5.tar.gz 85159 SHA256 264715b09a4d1caf0c0781dfac1d20845d5d163d8e07e57b843d34e5fb916a97 SHA512 198b08b7e62362bd749766857b6790b593d523e0c22483c3d73504e5fc8fa65984f20efff6549c78ddd63ca60e83c7e0a4228f70c81dd484f58c99dcbf551444 WHIRLPOOL 8c629e6da4cf353f331a2fb567bf705357507f0ee8575a01547682f73f805d66cb848bc434aeec940979e699f71476a6ceb79802c49d5274018e14e2ab0f1e12
+DIST MARC-Record-2.0.6.tar.gz 85134 SHA256 a23eae30f1ffb084bfd5fc06ffab2f308c6482b84b095ded1bb7f9b1da027d26 SHA512 7a3436adbe6e5365ec2810ebf3c64d22ae707cedbfccf02f562d253c7727c33f9ea36a47a7acdba12bbf32693b4c70913a0c551b5605388fb39fa379d099af8d WHIRLPOOL 8a6689448f521a80e272641e8f755cd761fe79043f66870f6573c9dc65e10b0c5f18310b13610bffd68fe9a755383912dd098d19351b6f50d2424aed0990822b
diff --git a/dev-perl/MARC-Record/metadata.xml b/dev-perl/MARC-Record/metadata.xml
new file mode 100644
index 000000000000..f9a22d58ee2d
--- /dev/null
+++ b/dev-perl/MARC-Record/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">MARC-Record</remote-id>
+ <remote-id type="cpan-module">MARC::Batch</remote-id>
+ <remote-id type="cpan-module">MARC::Field</remote-id>
+ <remote-id type="cpan-module">MARC::File</remote-id>
+ <remote-id type="cpan-module">MARC::File::Encode</remote-id>
+ <remote-id type="cpan-module">MARC::File::MicroLIF</remote-id>
+ <remote-id type="cpan-module">MARC::File::USMARC</remote-id>
+ <remote-id type="cpan-module">MARC::Record</remote-id>
+ </upstream>
+</pkgmetadata>