summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-21 23:32:46 +0100
committerSam James <sam@gentoo.org>2023-09-21 23:32:46 +0100
commit2df2645805b479ee4bdb6546049fab912bc958c5 (patch)
treec11a599ef8f5163af1163a686ffcf2e24c1f634f /dev-perl/Math-BigInt-GMP
parentvirtual/perl-Math-BigInt: add 1.999.840 (diff)
downloadgentoo-2df2645805b479ee4bdb6546049fab912bc958c5.tar.gz
gentoo-2df2645805b479ee4bdb6546049fab912bc958c5.tar.bz2
gentoo-2df2645805b479ee4bdb6546049fab912bc958c5.zip
dev-perl/Math-BigInt-GMP: add 1.601.300
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Math-BigInt-GMP')
-rw-r--r--dev-perl/Math-BigInt-GMP/Manifest1
-rw-r--r--dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.601.300.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-GMP/Manifest b/dev-perl/Math-BigInt-GMP/Manifest
index 241f5e5e0603..ea82b079c211 100644
--- a/dev-perl/Math-BigInt-GMP/Manifest
+++ b/dev-perl/Math-BigInt-GMP/Manifest
@@ -1,2 +1,3 @@
DIST Math-BigInt-GMP-1.6007.tar.gz 2459995 BLAKE2B 971f4785b2068d02d80a6a50b4aecea4ef584c7b0e679ddfd3001518425361b36a646d1919fd06fc14a2b18733fdf2534e11aea666d4999b3003cbd946ae27d7 SHA512 cdeaeec1e450e95d761cefc63c5262c0b43cf5fc5865e62d0463e34821541c2b83d156979c1e7a8157c9747ccf5e3cefa80ac52489a7ce3186425bc27c176512
DIST Math-BigInt-GMP-1.6012.tar.gz 2592463 BLAKE2B 5ff66bcabd76c756349fc84d7e5587d176e7b961e314268625ee6ab4921f774be8ebd0efef108636dc6bd36556a44f3442a8c89abbe19dc62fa36fcf6e7ed993 SHA512 cb8890b2f67f84a6328719f7a21173e8f6c6bbfe74a96d7d608d27c011d0b2390d6b9ea09e507cba56f885810f20bbc4aff3231f89312231d91d5c2e383893d6
+DIST Math-BigInt-GMP-1.6013.tar.gz 2592490 BLAKE2B ee029a0bfdc59ad925ce5ed8e4c3cda2ada302caca39d8ddc0d7b9f6bb51a55883f5e3fe519ff2999adbf3688355d338576643232d8cf3cfd1e7036c727db37a SHA512 0f4eba939f92c4f40f0b834846c10924167cb4368425d9617bf017ef536c99633d9220a929422b0111802eb1b881c1007573ea443016bd0f63f3f38efeb8ab1b
diff --git a/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.601.300.ebuild b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.601.300.ebuild
new file mode 100644
index 000000000000..2f421844b7da
--- /dev/null
+++ b/dev-perl/Math-BigInt-GMP/Math-BigInt-GMP-1.601.300.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.6013
+inherit perl-module
+
+DESCRIPTION="Use the GMP library for Math::BigInt routines"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=virtual/perl-Carp-1.220.0
+ >=virtual/perl-Math-BigInt-1.999.840
+ >=virtual/perl-XSLoader-0.20.0
+ >=dev-libs/gmp-4.0.0:0
+"
+DEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.580.0
+ test? ( >=virtual/perl-Test-Simple-0.820.0 )
+"
+
+src_test() {
+ perl_rm_files t/author-*.t t/00sig.t t/02pod.t t/03podcov.t
+ perl-module_src_test
+}