summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-01 01:25:47 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-01 01:25:47 +0200
commit3564203a08d8d5d069120b0cae5ab1c74b82f97b (patch)
tree0d433acb0f4721897fc09bf15fcac73429a55534 /dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
parentdev-perl/Mail-Builder: Add build fix for Perl 5.26, bug 617132 (diff)
downloadgentoo-3564203a08d8d5d069120b0cae5ab1c74b82f97b.tar.gz
gentoo-3564203a08d8d5d069120b0cae5ab1c74b82f97b.tar.bz2
gentoo-3564203a08d8d5d069120b0cae5ab1c74b82f97b.zip
dev-perl/Math-BigInt-Lite: Add build fix for Perl 5.26, bug 617134
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild')
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild27
1 files changed, 18 insertions, 9 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
index 519a06626cfa..8a4d4061f806 100644
--- a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,17 +13,26 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-RDEPEND=">=virtual/perl-Math-BigInt-1.940.0
- >=virtual/perl-Math-BigRat-0.190.0"
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.940.0
+ >=virtual/perl-Math-BigRat-0.190.0
+"
DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.420.0
- test? ( >=virtual/perl-Test-Simple-0.520.0 )"
+ test? ( >=virtual/perl-Test-Simple-0.520.0 )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
src_test() {
- local bad_files=( "t/pod_cov.t" "t/pod.t" );
- einfo "t/bigintpm.t is broken: https://rt.cpan.org/Public/Bug/Display.html?id=75667";
- bad_files+=( "t/bigintpm.t" );
- perl_rm_files "${bad_files[@]}";
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ # https://rt.cpan.org/Public/Bug/Display.html?id=75667"
+ bad_files+=( "t/bigintpm.t" )
- perl-module_src_test;
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
}