summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-27 00:13:46 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-27 00:14:06 +0200
commit02a57da6fde24edaecd38e4c0a2d115b93215065 (patch)
tree9616bdb5d7863bda46b1454f33098bfc0043a716 /dev-perl/Math-GMP/Math-GMP-2.200.0.ebuild
parentdev-perl/Alien-GMP: new package, needed by Math::GMP (diff)
downloadgentoo-02a57da6fde24edaecd38e4c0a2d115b93215065.tar.gz
gentoo-02a57da6fde24edaecd38e4c0a2d115b93215065.tar.bz2
gentoo-02a57da6fde24edaecd38e4c0a2d115b93215065.zip
dev-perl/Math-GMP: Version bump 2.20
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Math-GMP/Math-GMP-2.200.0.ebuild')
-rw-r--r--dev-perl/Math-GMP/Math-GMP-2.200.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Math-GMP/Math-GMP-2.200.0.ebuild b/dev-perl/Math-GMP/Math-GMP-2.200.0.ebuild
new file mode 100644
index 000000000000..e89617176f94
--- /dev/null
+++ b/dev-perl/Math-GMP/Math-GMP-2.200.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.20
+inherit perl-module
+
+DESCRIPTION="High speed arbitrary size integer math"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-AutoLoader
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ dev-libs/gmp:0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Alien-GMP-1.80.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"