summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-02-04 13:31:28 +1300
committerKent Fredric <kentnl@gentoo.org>2020-02-05 14:01:42 +1300
commite0cdfbe864ee2a6644b6ccdcb7a0429ed2d37d0c (patch)
treea53e966405af0eed60f19264969beafa35c0368f /dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
parentdev-perl/Math-Int64: Add w/ version=0.540.0 (diff)
downloadgentoo-e0cdfbe864ee2a6644b6ccdcb7a0429ed2d37d0c.tar.gz
gentoo-e0cdfbe864ee2a6644b6ccdcb7a0429ed2d37d0c.tar.bz2
gentoo-e0cdfbe864ee2a6644b6ccdcb7a0429ed2d37d0c.zip
dev-perl/Math-Int128: Add w/ version=0.220.0
Required for dev-perl/GeoIP2, as suggested by Tomáš Mózes Bug: https://github.com/gentoo/gentoo/pull/13973 Bug: https://bugs.gentoo.org/675494 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild')
-rw-r--r--dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild b/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
new file mode 100644
index 000000000000..693b54d44fd5
--- /dev/null
+++ b/dev-perl/Math-Int128/Math-Int128-0.220.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SALVA
+DIST_VERSION=0.22
+DIST_EXAMPLES=("benchmarks/*")
+inherit perl-module
+
+DESCRIPTION="Manipulate 128 bits integers in Perl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Exporter
+ >=dev-perl/Math-Int64-0.510.0
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ virtual/perl-Math-BigInt
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-eol.t"
+ "t/author-no-tabs.t"
+ "t/author-pod-spell.t"
+ "t/release-cpan-changes.t"
+ "t/release-pod-syntax.t"
+ "t/release-portability.t"
+ "t/release-synopsis.t"
+)