summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 20:57:16 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commitfc8a0bdd8f691090d830542c8b7e019af09a8279 (patch)
tree65c7649567976f9673c9897576cf5d4f63deed15 /dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild
parentdev-perl/Math-GMP: Bump to version 2.110.0 (diff)
downloadgentoo-fc8a0bdd8f691090d830542c8b7e019af09a8279.tar.gz
gentoo-fc8a0bdd8f691090d830542c8b7e019af09a8279.tar.bz2
gentoo-fc8a0bdd8f691090d830542c8b7e019af09a8279.zip
dev-perl/Math-ModInt: Bump to version 0.11.0
- EAPI - Fixup license - Cleanup tests Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild')
-rw-r--r--dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild b/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild
new file mode 100644
index 000000000000..8c24eaee6a58
--- /dev/null
+++ b/dev-perl/Math-ModInt/Math-ModInt-0.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MHASCH
+DIST_VERSION=0.011
+
+inherit perl-module
+
+DESCRIPTION="modular integer arithmetic"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="minimal test"
+
+PERL_RM_FILES=(
+ "t/90_pod.t"
+ "t/91_pod_cover_cp.t"
+ "t/92_consistency.t"
+ "t/93_examples.t"
+ "t/95_versions.t"
+ "t/99_signature.t"
+)
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Math-BigInt-1.991.0
+ !minimal? (
+ dev-perl/Math-BigInt-GMP
+ virtual/perl-Math-BigRat
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"