summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-04-01 03:37:25 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-03 23:23:43 +0200
commit0fa1b461a4c614c0fff14e79568b15db0209fed2 (patch)
tree36728de70e051ff01460a52998dfcc617b69b2d0 /dev-perl/Math-NumSeq/Math-NumSeq-71.0.0.ebuild
parentdev-perl/Math-Prime-XS: initial ebuild, version 0.260.0 (diff)
downloadgentoo-0fa1b461a4c614c0fff14e79568b15db0209fed2.tar.gz
gentoo-0fa1b461a4c614c0fff14e79568b15db0209fed2.tar.bz2
gentoo-0fa1b461a4c614c0fff14e79568b15db0209fed2.zip
dev-perl/Math-NumSeq: initial ebuild, version 71.0.0
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
Diffstat (limited to 'dev-perl/Math-NumSeq/Math-NumSeq-71.0.0.ebuild')
-rw-r--r--dev-perl/Math-NumSeq/Math-NumSeq-71.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-perl/Math-NumSeq/Math-NumSeq-71.0.0.ebuild b/dev-perl/Math-NumSeq/Math-NumSeq-71.0.0.ebuild
new file mode 100644
index 000000000000..1a71b405e809
--- /dev/null
+++ b/dev-perl/Math-NumSeq/Math-NumSeq-71.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR="KRYDE"
+DIST_VERSION=71
+inherit perl-module
+
+DESCRIPTION="number sequences (for example from OEIS)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test examples"
+
+RDEPEND="dev-perl/constant-defer
+ dev-perl/File-HomeDir
+ >=dev-perl/Math-Factor-XS-0.400.0
+ dev-perl/Math-Libm
+ >=dev-perl/Math-Prime-XS-0.260.0
+ >=dev-perl/Module-Pluggable-4.700.0
+ dev-perl/Module-Util
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-Module-Load
+ virtual/perl-Scalar-List-Utils"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Data-Float
+ virtual/perl-Test )"
+
+# Note: Examples need extra deps, but they're not critical LATER
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r examples/other/*
+ fi
+}