summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-21 06:46:04 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-21 06:48:00 +1300
commitfdd3ff5b8b1dcc0552e78268423653773dd1ea36 (patch)
tree129bce8dc752c2f49cc47180d6ce0247df27ab15 /dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild
parentdev-ruby/base32: Initial version (diff)
downloadgentoo-fdd3ff5b8b1dcc0552e78268423653773dd1ea36.tar.gz
gentoo-fdd3ff5b8b1dcc0552e78268423653773dd1ea36.tar.bz2
gentoo-fdd3ff5b8b1dcc0552e78268423653773dd1ea36.zip
dev-perl/Math-PlanePath: Bump to version 124.0.0
- Use DIST_EXAMPLES mechanic Upstream: - Add n_to_n_list function Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild')
-rw-r--r--dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild b/dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild
new file mode 100644
index 000000000000..a8174d48e391
--- /dev/null
+++ b/dev-perl/Math-PlanePath/Math-PlanePath-124.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR="KRYDE"
+DIST_VERSION=124
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Mathematical paths through the 2-D plane"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp test"
+
+RDEPEND="gmp? ( dev-perl/Math-BigInt-GMP )
+ dev-perl/Math-Libm
+ dev-perl/Math-NumSeq
+ >=dev-perl/constant-defer-5.0.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Math-BigInt"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test
+ dev-perl/Data-Float
+ dev-perl/Math-BigInt-Lite
+ dev-perl/Number-Fraction
+ )
+"