summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-02-04 16:14:09 +1300
committerKent Fredric <kentnl@gentoo.org>2020-02-05 14:01:53 +1300
commit72cec21dbd4723052c057a18949ba312d7935a2f (patch)
treeb10893707c16fcac1e6bbb4ba743887e178690f6 /dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild
parentdev-perl/MooX-StrictConstructor: Add w/ version=0.10.0 (diff)
downloadgentoo-72cec21dbd4723052c057a18949ba312d7935a2f.tar.gz
gentoo-72cec21dbd4723052c057a18949ba312d7935a2f.tar.bz2
gentoo-72cec21dbd4723052c057a18949ba312d7935a2f.zip
dev-perl/MaxMind-DB-Common: Add w/ v=0.40.1
Required for dev-perl/GeoIP2, as suggested by Tomáš Mózes Bug: https://github.com/gentoo/gentoo/pull/13973 Bug: https://bugs.gentoo.org/675494 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild')
-rw-r--r--dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild b/dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild
new file mode 100644
index 000000000000..cbe7dca4de9a
--- /dev/null
+++ b/dev-perl/MaxMind-DB-Common/MaxMind-DB-Common-0.40.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MAXMIND
+DIST_VERSION=0.040001
+inherit perl-module
+
+DESCRIPTION="Code shared by the MaxMind DB reader and writer modules"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Data-Dumper-Concise
+ dev-perl/DateTime
+ virtual/perl-Exporter
+ dev-perl/List-AllUtils
+ virtual/perl-Math-BigInt
+ dev-perl/Moo
+ dev-perl/MooX-StrictConstructor
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Sub-Quote
+ virtual/perl-autodie
+ dev-perl/namespace-autoclean
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+PERL_RM_FILES=(
+ "t/author-00-compile.t"
+ "t/author-eol.t"
+ "t/author-no-tabs.t"
+ "t/author-pod-spell.t"
+ "t/author-pod-syntax.t"
+ "t/author-test-version.t"
+ "t/release-cpan-changes.t"
+ "t/release-portability.t"
+ "t/release-synopsis.t"
+ "t/release-tidyall.t"
+)