summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-04 00:40:17 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-07-04 18:36:33 +0200
commite0b3cb3d990ac9dee3757df5ed4f2bc926f550b1 (patch)
treeecfa23b3beb9ecaada6a42a227b2543813772b80 /dev-perl/MediaWiki-API
parentdev-perl/MD5: EAPI=8 bump (diff)
downloadgentoo-e0b3cb3d990ac9dee3757df5ed4f2bc926f550b1.tar.gz
gentoo-e0b3cb3d990ac9dee3757df5ed4f2bc926f550b1.tar.bz2
gentoo-e0b3cb3d990ac9dee3757df5ed4f2bc926f550b1.zip
dev-perl/MediaWiki-API: Version bump 0.52
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/MediaWiki-API')
-rw-r--r--dev-perl/MediaWiki-API/Manifest1
-rw-r--r--dev-perl/MediaWiki-API/MediaWiki-API-0.520.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/MediaWiki-API/Manifest b/dev-perl/MediaWiki-API/Manifest
index d6700833b436..654afb598593 100644
--- a/dev-perl/MediaWiki-API/Manifest
+++ b/dev-perl/MediaWiki-API/Manifest
@@ -1 +1,2 @@
DIST MediaWiki-API-0.41.tar.gz 32857 BLAKE2B f68a8e204e3350aa3c97ce881dc0ffac27e9fdc8b931c8190019ab870dd55f1633aacfa15a1b502807782e8d3d8f2063382c43aa2896834e1771db6acd5ad370 SHA512 44d0af19ee5c6026b05d9844966b2469b5dfa7dadaf3c965327eef5ff420299e34dc301b4538bb67510d7c1b4d8d3151ff01deb9d3a4270b8a285b4254f99990
+DIST MediaWiki-API-0.52.tar.gz 32649 BLAKE2B 2ef7209dc6cc57c9310699222ec9a205c989f0d9ef7075d4528be44e4754857caf9db29e189c65e780d4ffafec2bfe9da02fc62e12d0b3a953212c2e7b7dea22 SHA512 a81ebc0355a87da974345164745bf660fb4b9af579e208d2274589db79721acb28bd8d6b71d5e8cac467aa59b168b35349cebe4dc4cc87e7c15082de53ba9635
diff --git a/dev-perl/MediaWiki-API/MediaWiki-API-0.520.0.ebuild b/dev-perl/MediaWiki-API/MediaWiki-API-0.520.0.ebuild
new file mode 100644
index 000000000000..04f9efbeda63
--- /dev/null
+++ b/dev-perl/MediaWiki-API/MediaWiki-API-0.520.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=EXOBUZZ
+DIST_VERSION=0.52
+inherit perl-module
+
+DESCRIPTION="A OO interface to the Mediawiki API"
+LICENSE="GPL-3+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ dev-perl/JSON
+ dev-perl/libwww-perl
+"
+BDEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.980.0
+ )
+"
+
+src_test() {
+ local my_test_control
+ my_test_control=${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}
+ if has network ${my_test_control}; then
+ perl_rm_files "t/98-pod-coverage.t" "t/99-pod.t"
+ else
+ perl_rm_files "t/98-pod-coverage.t" "t/99-pod.t" "t/10-api.t"
+ fi
+ perl-module_src_test
+}