summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Module-Signature
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Module-Signature')
-rw-r--r--dev-perl/Module-Signature/Manifest2
-rw-r--r--dev-perl/Module-Signature/Module-Signature-0.770.0.ebuild53
-rw-r--r--dev-perl/Module-Signature/Module-Signature-0.790.0.ebuild56
-rw-r--r--dev-perl/Module-Signature/metadata.xml9
4 files changed, 120 insertions, 0 deletions
diff --git a/dev-perl/Module-Signature/Manifest b/dev-perl/Module-Signature/Manifest
new file mode 100644
index 000000000000..6e31305c8191
--- /dev/null
+++ b/dev-perl/Module-Signature/Manifest
@@ -0,0 +1,2 @@
+DIST Module-Signature-0.77.tar.gz 94120 SHA256 bcb27b1514befaffc2f2a5bf7ea6a07cb16f3fb54f045a7cc290faf9761de800 SHA512 5c3fef54d0fdacba1b040bf1d8f9f7d9abca4717c2abe4b93da84de2fb54fb5d88c86e07d32443af5aa8bf9063575ec6733e8ff151a02c416b173e21aee13faf WHIRLPOOL f5b767b54215de0057ce280ccad79a684eeee593e1715fc46cddedcfa63c4c79b398f5bd7a551b4330d063bf0c862eb98a1d15c87e7824d4450e65ef5e1f35d3
+DIST Module-Signature-0.79.tar.gz 94207 SHA256 22df2ce097fb5d176efa951c782633d8debe594924a25ca66666252512ce462c SHA512 500049d841fec0f7a9ce3fe8dd5f89c09512d61d24bacca320a2c09b91c94d510aad514edfe0655906ed745cdfbf3cb226cddcf975dfd0934b8e46e276db3b62 WHIRLPOOL 625471b5ef840467e64521eb39eb8f5cfd573f5e875fc86db96f817f0ff98dda59971f8af3041cf52a40570be4916616013262e33d40fbc139acfc139390cbf6
diff --git a/dev-perl/Module-Signature/Module-Signature-0.770.0.ebuild b/dev-perl/Module-Signature/Module-Signature-0.770.0.ebuild
new file mode 100644
index 000000000000..400f5dc625ea
--- /dev/null
+++ b/dev-perl/Module-Signature/Module-Signature-0.770.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=AUDREYT
+MODULE_VERSION=0.77
+inherit perl-module
+
+DESCRIPTION="Module signature file manipulation "
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-MIME-Base64
+ dev-perl/PAR-Dist
+ virtual/perl-IO-Compress
+ dev-perl/crypt-cbc
+ dev-perl/Crypt-DES
+ dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-RIPEMD160
+ dev-perl/class-loader
+ dev-perl/tie-encryptedhash
+ dev-perl/convert-ascii-armour
+ dev-perl/data-buffer
+ dev-perl/digest-md2
+ >=dev-perl/math-pari-2.010603
+ dev-perl/crypt-random
+ dev-perl/crypt-primes
+ dev-perl/crypt-des-ede3
+ dev-perl/crypt-dsa
+ dev-perl/crypt-rsa
+ dev-perl/Convert-ASN1
+ dev-perl/convert-pem
+ dev-perl/Crypt-OpenPGP
+ app-crypt/gnupg
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/IPC-Run
+ )
+"
+
+SRC_TEST="do"
+
+src_test() {
+ export TEST_SIGNATURE="1"
+ perl-module_src_test
+}
diff --git a/dev-perl/Module-Signature/Module-Signature-0.790.0.ebuild b/dev-perl/Module-Signature/Module-Signature-0.790.0.ebuild
new file mode 100644
index 000000000000..3f370c5ac031
--- /dev/null
+++ b/dev-perl/Module-Signature/Module-Signature-0.790.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=AUDREYT
+MODULE_VERSION=0.79
+inherit perl-module
+
+DESCRIPTION="Module signature file manipulation"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-solaris"
+IUSE="test"
+
+# this needs checking, there is no indication in the metadata about any deps!!!
+RDEPEND="
+ virtual/perl-MIME-Base64
+ dev-perl/PAR-Dist
+ virtual/perl-IO-Compress
+ dev-perl/crypt-cbc
+ dev-perl/Crypt-DES
+ dev-perl/Crypt-Blowfish
+ dev-perl/Crypt-RIPEMD160
+ dev-perl/class-loader
+ dev-perl/tie-encryptedhash
+ dev-perl/convert-ascii-armour
+ dev-perl/data-buffer
+ dev-perl/digest-md2
+ >=dev-perl/math-pari-2.010603
+ dev-perl/crypt-random
+ dev-perl/crypt-primes
+ dev-perl/crypt-des-ede3
+ dev-perl/crypt-dsa
+ dev-perl/crypt-rsa
+ dev-perl/Convert-ASN1
+ dev-perl/convert-pem
+ dev-perl/Crypt-OpenPGP
+ app-crypt/gnupg
+ virtual/perl-File-Temp
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/IPC-Run
+ )
+"
+
+SRC_TEST="do parallel"
+
+src_test() {
+ export TEST_SIGNATURE="1"
+ perl-module_src_test
+}
diff --git a/dev-perl/Module-Signature/metadata.xml b/dev-perl/Module-Signature/metadata.xml
new file mode 100644
index 000000000000..14d7cdabbcb2
--- /dev/null
+++ b/dev-perl/Module-Signature/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Module-Signature</remote-id>
+ <remote-id type="cpan-module">Module::Signature</remote-id>
+ </upstream>
+</pkgmetadata>