summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-11-07 17:11:06 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2019-11-08 06:23:05 -0800
commitb4e5588fab9557784e1664fc250aeec87d9f6db2 (patch)
tree978e7847ea3202ecfc07d35e2a978ee06b5492bc /dev-perl/MogileFS-Server
parentdev-perl/MogileFS-Utils: bump (diff)
downloadgentoo-b4e5588fab9557784e1664fc250aeec87d9f6db2.tar.gz
gentoo-b4e5588fab9557784e1664fc250aeec87d9f6db2.tar.bz2
gentoo-b4e5588fab9557784e1664fc250aeec87d9f6db2.zip
dev-perl/MogileFS-Server: disable automatic tests
Fix the test deps, but also disable tests. The SQLite test suite no longer completes for permission reasons, and we cannot rely on being able to use a system MySQL or PostGreSQL. Fixes: https://bugs.gentoo.org/show_bug.cgi?id=699560 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-perl/MogileFS-Server')
-rw-r--r--dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild b/dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild
index 691d30b4fd8f..1ab8f1f30f2b 100644
--- a/dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild
+++ b/dev-perl/MogileFS-Server/MogileFS-Server-2.720.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,8 @@ inherit user perl-module
DESCRIPTION="Server for the MogileFS distributed file system"
HOMEPAGE="http://www.danga.com/mogilefs/ ${HOMEPAGE}"
-IUSE="mysql sqlite postgres"
+IUSE="mysql sqlite test postgres"
+REQUIRED_USE="test? ( sqlite ) || ( mysql sqlite postgres )"
SLOT="0"
LICENSE="|| ( Artistic GPL-2 )"
@@ -35,9 +36,9 @@ RDEPEND="dev-perl/Net-Netmask
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}/${P}-gentoo-init-conf.patch"
+ "${FILESDIR}/${PN}-2.720.0-gentoo-init-conf.patch"
)
-DIST_TEST="do"
+DIST_TEST="never"
MOGILE_USER="mogile"
@@ -75,3 +76,7 @@ pkg_postinst() {
chmod 640 "${ROOT}"/etc/mogilefs/{mogilefsd,mogstored}.conf
chown root:${MOGILE_USER} "${ROOT}"/etc/mogilefs/{mogilefsd,mogstored}.conf
}
+
+#src_test() {
+# emake test MOGTEST_DBUSER=mogile MOGTEST_DBNAME=tmp_mogiletest MOGTEST_DBTYPE=SQLite
+#}