summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-26 21:49:50 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-06-26 21:49:50 +0200
commit0a5a3b40bcb798be9abb5c513fca7e6cf4312b58 (patch)
tree61efa25abdcdac37f08e49ee4eee49ecfeda7242 /dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild
parentdev-perl/LWP-Online: Add build fix for Perl 5.26, bug 617054 (diff)
downloadgentoo-0a5a3b40bcb798be9abb5c513fca7e6cf4312b58.tar.gz
gentoo-0a5a3b40bcb798be9abb5c513fca7e6cf4312b58.tar.bz2
gentoo-0a5a3b40bcb798be9abb5c513fca7e6cf4312b58.zip
dev-perl/Monitoring-Plugin: Add build fix for Perl 5.26, bug 617116
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild')
-rw-r--r--dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild b/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild
index 0114d26c50aa..657271f5d510 100644
--- a/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild
+++ b/dev-perl/Monitoring-Plugin/Monitoring-Plugin-0.390.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR=NIERLEIN
-MODULE_VERSION=0.39
+DIST_AUTHOR=NIERLEIN
+DIST_VERSION=0.39
inherit perl-module
DESCRIPTION="Modules to streamline Nagios, Icinga, Shinken, etc. plugins"
@@ -26,4 +26,8 @@ DEPEND="${RDEPEND}
test? ( >=virtual/perl-Test-Simple-0.620.0 )
"
-SRC_TEST="do parallel"
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}