summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-21 15:08:59 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-21 16:36:18 +1300
commit0e23416b7d3efeb4aea19fdb7beacac1f37f5bed (patch)
treede66621c90ff643f09d5dfc568d20585674b0b70 /dev-perl/MooseX-LazyRequire/MooseX-LazyRequire-0.110.0.ebuild
parentdev-perl/Log-Dispatchouli: Add w/ version 2.15.0 (diff)
downloadgentoo-0e23416b7d3efeb4aea19fdb7beacac1f37f5bed.tar.gz
gentoo-0e23416b7d3efeb4aea19fdb7beacac1f37f5bed.tar.bz2
gentoo-0e23416b7d3efeb4aea19fdb7beacac1f37f5bed.zip
dev-perl/MooseX-LazyRequire: Add w/ version 0.110.0
Required for dev-perl/Dist-Zilla Previously maintained in ::perl-experimental by Michele Beltrame, Torsten Veller and myself since August 2009 Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/MooseX-LazyRequire/MooseX-LazyRequire-0.110.0.ebuild')
-rw-r--r--dev-perl/MooseX-LazyRequire/MooseX-LazyRequire-0.110.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/MooseX-LazyRequire/MooseX-LazyRequire-0.110.0.ebuild b/dev-perl/MooseX-LazyRequire/MooseX-LazyRequire-0.110.0.ebuild
new file mode 100644
index 000000000000..9ef0c137d091
--- /dev/null
+++ b/dev-perl/MooseX-LazyRequire/MooseX-LazyRequire-0.110.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.11
+inherit perl-module
+
+DESCRIPTION="Required attributes which fail only when trying to use them"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+# r: Moose::Exporter -> Moose
+# r: Moose::Role -> Moose
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Moose-0.940.0
+ >=dev-perl/aliased-0.300.0
+ dev-perl/namespace-autoclean
+"
+# t: Test::More -> Test-Simple
+# t: strict,warnings -> perl
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.37.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ )
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"