summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-03-31 00:39:41 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-03 23:23:43 +0200
commit8aa40821ad94d6d17201abd4d4d9a1df50431b2a (patch)
tree2dec43365e25872722e8671617bdef14c092b7a0 /dev-perl/Net-Bonjour/Net-Bonjour-0.960.0.ebuild
parentdev-perl/Module-Build-WithXSpp: initial-ebuild, version 0.140.0 (diff)
downloadgentoo-8aa40821ad94d6d17201abd4d4d9a1df50431b2a.tar.gz
gentoo-8aa40821ad94d6d17201abd4d4d9a1df50431b2a.tar.bz2
gentoo-8aa40821ad94d6d17201abd4d4d9a1df50431b2a.zip
dev-perl/Net-Bonjour: initial ebuild, version 0.960.0
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
Diffstat (limited to 'dev-perl/Net-Bonjour/Net-Bonjour-0.960.0.ebuild')
-rw-r--r--dev-perl/Net-Bonjour/Net-Bonjour-0.960.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Net-Bonjour/Net-Bonjour-0.960.0.ebuild b/dev-perl/Net-Bonjour/Net-Bonjour-0.960.0.ebuild
new file mode 100644
index 000000000000..2e1711a920dc
--- /dev/null
+++ b/dev-perl/Net-Bonjour/Net-Bonjour-0.960.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR="CHLIGE"
+DIST_VERSION="0.96"
+inherit perl-module
+
+DESCRIPTION="Module for DNS service discovery (Apple's Bonjour)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test examples"
+
+RDEPEND="
+ >=dev-perl/Net-DNS-0.500.0
+ >=virtual/perl-Socket-1.750.0"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r demo/*
+ fi
+}