summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-12-31 15:47:10 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-12-31 16:07:59 +0100
commitc426d288182183de62f96eec7b7773cef410ee26 (patch)
treef5bdcc796249c232ca188368d5e3d69dff725801 /dev-perl/Net-CUPS
parentsys-fs/dd-rescue: Removed old. (diff)
downloadgentoo-c426d288182183de62f96eec7b7773cef410ee26.tar.gz
gentoo-c426d288182183de62f96eec7b7773cef410ee26.tar.bz2
gentoo-c426d288182183de62f96eec7b7773cef410ee26.zip
dev-perl/Net-CUPS: Remove old
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/Net-CUPS')
-rw-r--r--dev-perl/Net-CUPS/Manifest1
-rw-r--r--dev-perl/Net-CUPS/Net-CUPS-0.610.0-r2.ebuild23
-rw-r--r--dev-perl/Net-CUPS/files/Net-CUPS-0.610.0-cups16.patch165
3 files changed, 0 insertions, 189 deletions
diff --git a/dev-perl/Net-CUPS/Manifest b/dev-perl/Net-CUPS/Manifest
index 0dbc9818edef..03b2a9439ef9 100644
--- a/dev-perl/Net-CUPS/Manifest
+++ b/dev-perl/Net-CUPS/Manifest
@@ -1,2 +1 @@
-DIST Net-CUPS-0.61.tar.gz 83893 SHA256 fd4a5a86038df9dfe57dcfed78b2d045e4b18d507a6fa5a8f82ecb3a732e0e35 SHA512 6e906dfebd7a5970f393f8187808049004d6b89fc268bb89abb4dca43145ec97ea45dd3faa51a04de2843a2aedc8051bcb88ab688f4a9886acc188166e2c2cf7 WHIRLPOOL df2ac30aa164ab8e6494bcd0cad59143020df8e50d670d9fd6dcfd0ec986c73363788435ae83b6bc7ac67cdf430cd6550a5926038f124e950735caa47adfae53
DIST Net-CUPS-0.63.tar.gz 86922 SHA256 a548a34f6258970375d3f5173e070b65a128bbf77ebb0cc6e88ebba55c15a687 SHA512 ac407d1a0ebb686cd1f12f76516581073da90cf129a24ef57f10facf0a879ee9a13bdf0b498163c998030f9ec837fc237f440d24894e997e7e57ad2a13693b8a WHIRLPOOL e5e52e666bd4388ac57da37a4205362a6ea4bb1792b60e90bbd7c686b786fc0d0415893c6601a0916cf9bab4882b442cc588c71b2c4b586c1f314f92fc505606
diff --git a/dev-perl/Net-CUPS/Net-CUPS-0.610.0-r2.ebuild b/dev-perl/Net-CUPS/Net-CUPS-0.610.0-r2.ebuild
deleted file mode 100644
index 4ea35440162e..000000000000
--- a/dev-perl/Net-CUPS/Net-CUPS-0.610.0-r2.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-MODULE_AUTHOR=DHAGEMAN
-MODULE_VERSION=0.61
-inherit perl-module
-
-DESCRIPTION="CUPS C API Interface"
-
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="net-print/cups"
-DEPEND="${RDEPEND}
- test? ( virtual/perl-Test-Simple )"
-
-PATCHES=( "${FILESDIR}/${P}-cups16.patch" )
-
-SRC_TEST="do"
diff --git a/dev-perl/Net-CUPS/files/Net-CUPS-0.610.0-cups16.patch b/dev-perl/Net-CUPS/files/Net-CUPS-0.610.0-cups16.patch
deleted file mode 100644
index 4c5bf66ca6d2..000000000000
--- a/dev-perl/Net-CUPS/files/Net-CUPS-0.610.0-cups16.patch
+++ /dev/null
@@ -1,165 +0,0 @@
-diff --git a/CUPS.xs b/CUPS.xs
-index 2da9558..109f73f 100644
---- a/CUPS.xs
-+++ b/CUPS.xs
-@@ -5,9 +5,17 @@
- #include "ppport.h"
-
- #include <cups/cups.h>
-+#if (CUPS_VERSION_MAJOR > 1) || (CUPS_VERSION_MINOR > 5)
-+#define HAVE_CUPS_1_6 1
-+#endif
-+
- /*#include <cups/backend.h>*/
- #include <cups/http.h>
--#include <cups/image.h>
-+#ifdef HAVE_CUPS_1_6
-+ #include <cupsfilters/image.h>
-+#else
-+ #include <cups/image.h>
-+#endif
- #include <cups/ipp.h>
- #include <cups/ppd.h>
- #include <cups/file.h>
-@@ -19,6 +27,17 @@
- #include "const-c.inc"
- #include "packer.c"
-
-+#ifndef HAVE_CUPS_1_6
-+#define ippGetGroupTag(attr) attr->group_tag
-+#define ippGetName(attr) attr->name
-+#define ippGetValueTag(attr) attr->value_tag
-+#define ippGetInteger(attr, element) attr->values[element].integer
-+#define ippGetString(attr, element, language) attr->values[element].string.text
-+#define ippGetStatusCode(ipp) ipp->request.status.status_code
-+#define ippFirstAttribute(ipp) ipp->current = ipp->attrs
-+#define ippNextAttribute(ipp) ipp->current = ipp->current->next
-+#endif
-+
- static SV *password_cb = (SV*) NULL;
-
- const char *
-@@ -200,7 +219,7 @@ NETCUPS_getPPDMakes()
- if (response != NULL) {
- attr = ippFindAttribute(response, "ppd-make", IPP_TAG_TEXT);
- rv = sv_newmortal();
-- sv_setpv(rv, attr->values[0].string.text);
-+ sv_setpv(rv, ippGetString(attr, 0, NULL));
- XPUSHs(rv);
- count++;
-
-@@ -211,7 +230,7 @@ NETCUPS_getPPDMakes()
- }
-
- rv = sv_newmortal();
-- sv_setpv(rv, attr->values[0].string.text);
-+ sv_setpv(rv, ippGetString(attr, 0, NULL));
- XPUSHs(rv);
- count++;
- }
-@@ -252,7 +271,7 @@ NETCUPS_getAllPPDs ()
- "ppd-make-and-model",
- IPP_TAG_TEXT);
- rv = sv_newmortal();
-- sv_setpv(rv, attr->values[0].string.text);
-+ sv_setpv(rv, ippGetString(attr, 0, NULL));
- XPUSHs(rv);
- count++;
- while (attr != NULL) {
-@@ -263,7 +282,7 @@ NETCUPS_getAllPPDs ()
- break;
- }
- rv = sv_newmortal();
-- sv_setpv(rv, attr->values[0].string.text);
-+ sv_setpv(rv, ippGetString(attr, 0, NULL));
- XPUSHs(rv);
- count++;
- }
-@@ -356,14 +375,14 @@ NETCUPS_getPPDFileName(ppdfilename);
- if (response != NULL) {
- attr = ippFindAttribute(response, "ppd-name", IPP_TAG_NAME );
- while ((attr != NULL) && (i < 1)) {
-- tmpppd = attr->values[0].string.text;
-+ tmpppd = ippGetString(attr, 0, NULL);
- attr = ippFindNextAttribute(response,
- "ppd-make",
- IPP_TAG_TEXT);
- attr = ippFindNextAttribute(response,
- "ppd-make-and-model",
- IPP_TAG_TEXT);
-- if (strcmp(attr->values[0].string.text, ppdfilename) == 0 ) {
-+ if (strcmp(ippGetString(attr, 0, NULL), ppdfilename) == 0 ) {
- /* return tmpppd; */
- strcpy(test, tmpppd);
- break;
-@@ -410,12 +429,12 @@ NETCUPS_getDeviceAttribute( device, attribute, attribute_type )
- attr = ippFindNextAttribute(response, "printer-name", IPP_TAG_NAME);
-
- while (attr != NULL) {
-- if (strcmp(attr->values[0].string.text, device) == 0) {
-+ if (strcmp(ippGetString(attr, 0, NULL), device) == 0) {
- attr = ippFindNextAttribute( response,
- attribute,
- attribute_type);
- rv = sv_newmortal();
-- sv_setpv( rv, attr->values[0].string.text);
-+ sv_setpv( rv, ippGetString(attr, 0, NULL));
- XPUSHs( rv );
- break;
- }
-@@ -858,15 +877,15 @@ NETCUPS_getAttributes( ipp )
- SV* rv = NULL;
- int count = 0;
- ipp_attribute_t* attr = NULL;
-- for (attr = ipp->attrs; attr != NULL; attr = attr->next)
-+ for (attr = ippFirstAttribute(ipp); attr != NULL; attr = ippNextAttribute(ipp))
- {
-- while (attr != NULL && attr->group_tag != IPP_TAG_JOB)
-- attr = attr->next;
-+ while (attr != NULL && ippGetGroupTag(attr) != IPP_TAG_JOB)
-+ attr = ippNextAttribute(ipp);
-
- if (attr == NULL)
- break;
- rv = sv_newmortal();
-- sv_setpv( rv, attr->name );
-+ sv_setpv( rv, ippGetName(attr) );
- XPUSHs( rv );
- count++;
- }
-@@ -880,27 +899,27 @@ NETCUPS_getAttributeValue( ipp, name )
- SV* rv = NULL;
- int count = 0;
- ipp_attribute_t* attr = NULL;
-- for (attr = ipp->attrs; attr != NULL; attr = attr->next)
-+ for (attr = ippFirstAttribute(ipp); attr != NULL; attr = ippNextAttribute(ipp))
- {
-- while (attr != NULL && attr->group_tag != IPP_TAG_JOB)
-- attr = attr->next;
-+ while (attr != NULL && ippGetGroupTag(attr) != IPP_TAG_JOB)
-+ attr = ippNextAttribute(ipp);
-
- if (attr == NULL)
- break;
-
-- if( !strcmp( attr->name, name ) )
-+ if( !strcmp( ippGetName(attr), name ) )
- {
- rv = sv_newmortal();
-- if( ( attr->value_tag == IPP_TAG_INTEGER ) ||
-- ( attr->value_tag == IPP_TAG_ENUM ) )
-+ if( ( ippGetValueTag(attr) == IPP_TAG_INTEGER ) ||
-+ ( ippGetValueTag(attr) == IPP_TAG_ENUM ) )
- {
- /* We have a number with any luck ... */
-- sv_setiv( rv, attr->values[0].integer );
-+ sv_setiv( rv, ippGetInteger(attr, 0) );
- }
- else
- {
- /* We have a string ... maybe ... try to set it. */
-- sv_setpv( rv, attr->values[0].string.text );
-+ sv_setpv( rv, ippGetString(attr, 0, NULL) );
- }
-
- XPUSHs( rv );