summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2015-12-26 13:44:55 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2015-12-26 13:52:34 +0100
commiteda3a7d42b3e34c8b40ee854776fe40f343efd32 (patch)
treef4073ec7dd88b5e08601f33e9237199a46766b49 /dev-perl/Net-DNS/Net-DNS-1.40.0.ebuild
parentdev-perl/Net-DBus: Version bump (diff)
downloadgentoo-eda3a7d42b3e34c8b40ee854776fe40f343efd32.tar.gz
gentoo-eda3a7d42b3e34c8b40ee854776fe40f343efd32.tar.bz2
gentoo-eda3a7d42b3e34c8b40ee854776fe40f343efd32.zip
dev-perl/Net-DNS: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-perl/Net-DNS/Net-DNS-1.40.0.ebuild')
-rw-r--r--dev-perl/Net-DNS/Net-DNS-1.40.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Net-DNS/Net-DNS-1.40.0.ebuild b/dev-perl/Net-DNS/Net-DNS-1.40.0.ebuild
new file mode 100644
index 000000000000..6082ded51ff8
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-1.40.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=NLNETLABS
+DIST_VERSION=1.04
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6 test"
+
+RDEPEND="
+ >=dev-perl/Digest-HMAC-1.30.0
+ >=virtual/perl-Digest-MD5-2.130.0
+ >=virtual/perl-Digest-SHA-5.230.0
+ >=virtual/perl-File-Spec-0.860.0
+ >=virtual/perl-MIME-Base64-2.110.0
+ ipv6? (
+ dev-perl/IO-Socket-INET6
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ )
+"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}