summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-08 10:46:58 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-08 10:47:38 +1300
commitd9ba115614ecbeecb8fd940faf051359f60a144c (patch)
tree35b8bcb83b140b97646de0ecea7388fc11740dad /dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild
parentkde-apps/cantor: Set SRC_URI (diff)
downloadgentoo-d9ba115614ecbeecb8fd940faf051359f60a144c.tar.gz
gentoo-d9ba115614ecbeecb8fd940faf051359f60a144c.tar.bz2
gentoo-d9ba115614ecbeecb8fd940faf051359f60a144c.zip
dev-perl/Net-Daemon: Fix configfile reading bug #633722
- r1bump because this changes runtime code - will need restable because this needs testing to happen - tests restored, please do not disable them all again - EAPI6 Bug: https://bugs.gentoo.org/633722 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild')
-rw-r--r--dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild b/dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild
new file mode 100644
index 000000000000..bf39a6b8edd4
--- /dev/null
+++ b/dev-perl/Net-Daemon/Net-Daemon-0.480.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MNOONING
+DIST_VERSION=0.48
+inherit perl-module
+
+DESCRIPTION="Abstract base class for portable servers"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+PATCHES=(
+ "${FILESDIR}/${P}-perl526.patch"
+)
+# loop-t and loop-child-t race-condition
+# due to Net::Daemon::Test writing
+# specific files to CWD
+DIST_TEST="do"