summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-01-08 19:02:07 +1300
committerKent Fredric <kentnl@gentoo.org>2017-01-08 19:26:21 +1300
commit492bfc536949f4d478f8f59bcb6a7ee1016d1fa7 (patch)
treef557523c604911163574fe3544ddc1e38f86dc4c /dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild
parentdev-perl/Net-SSLeay: Bump to version 1.800.0 (diff)
downloadgentoo-492bfc536949f4d478f8f59bcb6a7ee1016d1fa7.tar.gz
gentoo-492bfc536949f4d478f8f59bcb6a7ee1016d1fa7.tar.bz2
gentoo-492bfc536949f4d478f8f59bcb6a7ee1016d1fa7.zip
dev-perl/Net-HTTP: Bump to version 6.120.0
Upstream: - Fix my_readline() hanging when keep-alive => 1 and response_size is an exact multiple of 1024 - Avoid ignoring pending data from Net::SSL Keywording: - Dropped amd64-fbsd and arm64 due to new dependencies Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild')
-rw-r--r--dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild b/dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild
new file mode 100644
index 000000000000..5c86654bb6b5
--- /dev/null
+++ b/dev-perl/Net-HTTP/Net-HTTP-6.120.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.12
+inherit perl-module
+
+DESCRIPTION="Low-level HTTP connection (client)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal test"
+
+PATCHES=( "${FILESDIR}/${DIST_VERSION}-networktest.patch" )
+RDEPEND="
+ !minimal? (
+ virtual/perl-IO-Socket-IP
+ dev-perl/IO-Socket-INET6
+ >=dev-perl/IO-Socket-SSL-1.380.0
+ )
+ virtual/perl-Carp
+ !<dev-perl/libwww-perl-6
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-IO
+ virtual/perl-IO-Compress
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Socket
+ virtual/perl-Test-Simple
+ )
+"