summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-30 12:56:07 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-30 12:56:07 +1200
commite44c062bf3ede98bd22c779b6809a7d4aa0d9b78 (patch)
tree550f4e8830057ff0025adb343ba9267f83705c58 /dev-perl/Net-HTTP/Net-HTTP-6.160.0.ebuild
parentdev-perl/Params-Validate: Bump to version 1.280.0 (diff)
downloadgentoo-e44c062bf3ede98bd22c779b6809a7d4aa0d9b78.tar.gz
gentoo-e44c062bf3ede98bd22c779b6809a7d4aa0d9b78.tar.bz2
gentoo-e44c062bf3ede98bd22c779b6809a7d4aa0d9b78.zip
dev-perl/Net-HTTP: Bump to version 6.160.0
Upstream: - Use newer IO::Socket::SSL Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Net-HTTP/Net-HTTP-6.160.0.ebuild')
-rw-r--r--dev-perl/Net-HTTP/Net-HTTP-6.160.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Net-HTTP/Net-HTTP-6.160.0.ebuild b/dev-perl/Net-HTTP/Net-HTTP-6.160.0.ebuild
new file mode 100644
index 000000000000..6a472b846bd8
--- /dev/null
+++ b/dev-perl/Net-HTTP/Net-HTTP-6.160.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=OALDERS
+DIST_VERSION=6.16
+inherit perl-module
+
+DESCRIPTION="Low-level HTTP connection (client)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal test"
+
+RDEPEND="
+ !minimal? (
+ virtual/perl-IO-Socket-IP
+ dev-perl/IO-Socket-INET6
+ >=dev-perl/IO-Socket-SSL-2.12.0
+ )
+ virtual/perl-Carp
+ !<dev-perl/libwww-perl-6
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-IO
+ virtual/perl-IO-Compress
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-Socket
+ virtual/perl-Test-Simple
+ )
+"