summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-01 20:38:31 +1300
committerKent Fredric <kentfredric@gmail.com>2016-03-01 20:39:47 +1300
commit4e62d2ece234b73ab40be0635e4ca260696b4d58 (patch)
tree4cd56e6b4f91f22e44b241181f582619bd712226 /dev-perl/Net-HTTP/Net-HTTP-6.90.0.ebuild
parentdev-ruby/rbpdf: cleanup (diff)
downloadgentoo-4e62d2ece234b73ab40be0635e4ca260696b4d58.tar.gz
gentoo-4e62d2ece234b73ab40be0635e4ca260696b4d58.tar.bz2
gentoo-4e62d2ece234b73ab40be0635e4ca260696b4d58.zip
dev-perl/Net-HTTP: Bump to version 6.90.0
- EAPI6 - Test cleanup esp Network special casing. Upstream: - Better support for IPv6 and SSL Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Net-HTTP/Net-HTTP-6.90.0.ebuild')
-rw-r--r--dev-perl/Net-HTTP/Net-HTTP-6.90.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Net-HTTP/Net-HTTP-6.90.0.ebuild b/dev-perl/Net-HTTP/Net-HTTP-6.90.0.ebuild
new file mode 100644
index 000000000000..8257b714df01
--- /dev/null
+++ b/dev-perl/Net-HTTP/Net-HTTP-6.90.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=6.09
+inherit perl-module
+
+DESCRIPTION="Low-level HTTP connection (client)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal"
+
+PATCHES=( "${FILESDIR}/networktest.patch" )
+RDEPEND="
+ !minimal? (
+ >=dev-perl/IO-Socket-SSL-1.380.0
+ )
+ !<dev-perl/libwww-perl-6
+ virtual/perl-Compress-Raw-Zlib
+ virtual/perl-IO
+ virtual/perl-IO-Compress
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"