summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-26 15:40:35 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-26 15:41:03 +1300
commit619e6241484602eda67523a66d1b6ac71ac505e6 (patch)
treee6d2fbc469da08378d4048b1c07938943d0a931b /dev-perl/Net-SSLeay/Net-SSLeay-1.820.0.ebuild
parentprofiles: Mask for removal x11-drivers/xf86-input-* unmaintained drivers (diff)
downloadgentoo-619e6241484602eda67523a66d1b6ac71ac505e6.tar.gz
gentoo-619e6241484602eda67523a66d1b6ac71ac505e6.tar.bz2
gentoo-619e6241484602eda67523a66d1b6ac71ac505e6.zip
dev-perl/Net-SSLeay: Bump to version 1.820.0 re bug #614462
- Replace sed hacks with real patches ( metadata retroactively pulled from git history and reconstructed to retain intent, as the existing sed commands had entirely ceased working, silently ) Upstream: - Implement SSL_{CTX_,}set_psk_client_callback() - Support NPN-less libressl - Skip NPN-test with libressl - Free ocsp_response only when allocated - Lots of new bindings - Fix key block size calculation with AEAD ciphers - Fix test failures without '.' in @INC Bug: https://bugs.gentoo.org/614462 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Net-SSLeay/Net-SSLeay-1.820.0.ebuild')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.820.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.820.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.820.0.ebuild
new file mode 100644
index 000000000000..28d51fd95b04
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.820.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MIKEM
+DIST_VERSION=1.82
+DIST_EXAMPLES=("examples/*")
+inherit multilib perl-module
+
+DESCRIPTION="Perl extension for using OpenSSL"
+
+LICENSE="openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test minimal examples"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ )
+ virtual/perl-Test-Simple
+ )
+"
+export OPTIMIZE="$CFLAGS"
+export OPENSSL_PREFIX=${EPREFIX}/usr
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.82-respect-cflags.patch"
+ "${FILESDIR}/${PN}-1.82-fix-libdir.patch"
+ "${FILESDIR}/${PN}-1.82-fix-network-tests.patch"
+)
+
+src_prepare() {
+ use test && perl_rm_files 't/local/01_pod.t' 't/local/02_pod_coverage.t' 't/local/kwalitee.t'
+ perl-module_src_prepare
+}
+
+src_configure() {
+ if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ export NETWORK_TESTS=yes
+ else
+ use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
+ export NETWORK_TESTS=no
+ fi
+ export LIBDIR=$(get_libdir)
+ perl-module_src_configure
+}