summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-05-25 13:22:02 +0300
committerKent Fredric <kentnl@gentoo.org>2019-07-10 20:13:00 +1200
commit19f6b8c827f9212ccd27e7d24de21c07630ecac2 (patch)
tree76bac0990f64cdf5430a6ca43821981f76595b25 /dev-perl/Net-SSLeay
parentnet-dns/nsd: Bump to version 4.2.1 (diff)
downloadgentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.tar.gz
gentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.tar.bz2
gentoo-19f6b8c827f9212ccd27e7d24de21c07630ecac2.zip
dev-perl/Net-SSLeay: Bump version to 1.880.0
- Restore previously broken tests - CFLAGS repsect logic reworked for upstream tooling changes - LIBDIR respect logic reworked for upstream tooling changes - NETWORK_TESTS handling logic reworked for upstream tooling changes Upstream: - Clarify licensing to be consistently Artistic-2 - Improved OpenSSL 1.1.1 support - Improved TLS 1.3 support - Fixed memory leaks in cb_data_advanced_put Bug: https://rt.cpan.org/Ticket/Display.html?id=106314 Bug: https://rt.cpan.org/Ticket/Display.html?id=128207 Closes: https://bugs.gentoo.org/556010 Closes: https://bugs.gentoo.org/684308 Closes: https://bugs.gentoo.org/686730 Closes: https://github.com/gentoo/gentoo/pull/12101 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Stefan Strogin <steils@gentoo.org> Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Net-SSLeay')
-rw-r--r--dev-perl/Net-SSLeay/Manifest1
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild63
-rw-r--r--dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-libdir.patch27
-rw-r--r--dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-network-tests.patch17
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Manifest b/dev-perl/Net-SSLeay/Manifest
index 4337772143ce..478196d6e2ac 100644
--- a/dev-perl/Net-SSLeay/Manifest
+++ b/dev-perl/Net-SSLeay/Manifest
@@ -1,2 +1,3 @@
DIST Net-SSLeay-1.82.tar.gz 399194 BLAKE2B 0c8aeb3085b102b71284266904ee88a8558070644aaa6dd0c5f78db0bfccb0e7456c8ba62a549d7ab245a02ddc7e856bc326d503f63268ee0761290e41b97e4d SHA512 758c41f4916a55b5085167e5c6a2732a5ee70dbeb8f42e791cd957957ba4a59f724c072d3fa50a6b42ae3b22cf3ecb8738c3f8963990a7030117b73c2dcc0716
DIST Net-SSLeay-1.85.tar.gz 418349 BLAKE2B 0f639145e5be9406264cc7ef6240a30e0d62e631bfe29b8d1cbc85ab3bf721e8d344a8472faaa87816a5d148cedd7f13faeec925d0632fc1b75ecd1c5c44f6d1 SHA512 74e0f2f56b707f1ff845c78c1fa7ce26a71b8f943bb99e994d4e065d1f42259fe4cd1a6a17d333459727534158f9541f116dbc8515122380807d9450b0faa26b
+DIST Net-SSLeay-1.88.tar.gz 436215 BLAKE2B 1a58296693cf41c464ac67a7f630598ccbf261ed0374a5381e3f718361b66418d13b5357bf7a49267a9e3bcd8d423fdedccd6b60d34aa60c975a5e3d1b0688e7 SHA512 37fc32ec003337f3dc18bf928139079a3127628c6fa0fccaed0c27b6bf3b216c2c5338ed1aaf9408b0add3be549df3218d3c5a6d6299793c1329d8a0813a1682
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
new file mode 100644
index 000000000000..9d69832552c8
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.880.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CHRISN
+DIST_VERSION=1.88
+DIST_EXAMPLES=("examples/*")
+inherit multilib perl-module
+
+DESCRIPTION="Perl extension for using OpenSSL"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl test minimal examples"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ virtual/perl-MIME-Base64
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ dev-perl/Test-Exception
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ )
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.88-fix-network-tests.patch"
+ "${FILESDIR}/${PN}-1.88-fix-libdir.patch"
+)
+PERL_RM_FILES=(
+ # Hateful author tests
+ 't/local/01_pod.t'
+ 't/local/02_pod_coverage.t'
+ 't/local/kwalitee.t'
+)
+
+src_configure() {
+ if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ export NETWORK_TESTS=yes
+ else
+ use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
+ export NETWORK_TESTS=no
+ fi
+ export LIBDIR=$(get_libdir)
+ perl-module_src_configure
+}
+
+src_compile() {
+ mymake=(
+ OPTIMIZE="${CFLAGS}"
+ OPENSSL_PREFIX="${EPREFIX}"/usr
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-libdir.patch b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-libdir.patch
new file mode 100644
index 000000000000..d78acb9c6153
--- /dev/null
+++ b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-libdir.patch
@@ -0,0 +1,27 @@
+Bug: https://bugs.gentoo.org/416339
+
+The previous patch for the above bug report used $ENV{LIBDIR} but this
+wasn't enough to help with cross-compiling. We could use $ENV{SYSROOT}
+but this results in a bogus RPATH entry. It is better to simply trust
+the toolchain, which may have its own sysroot applied.
+
+Cross-compiling Perl modules requires additional hackery but at least
+that hackery will work now. :)
+
+Chewi
+2017/12/03
+
+diff -Naur a/Makefile.PL b/Makefile.PL
+--- a/Makefile.PL 2017-10-13 01:38:01.000000000 +0100
++++ b/Makefile.PL 2017-12-03 10:52:27.304861804 +0000
+@@ -141,10 +141,8 @@
+ cccdlflags => '',
+ };
+ for ("$prefix/include", "$prefix/inc32", '/usr/kerberos/include') {
+- push @{$opts->{inc_paths}}, $_ if -f "$_/openssl/ssl.h";
+ }
+ for ($prefix, "$prefix/lib64", "$prefix/lib", "$prefix/out32dll") {
+- push @{$opts->{lib_paths}}, $_ if -d $_;
+ }
+
+ my $rsaref = $self->ssleay_is_rsaref;
diff --git a/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-network-tests.patch b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-network-tests.patch
new file mode 100644
index 000000000000..a98c4c8a0c9c
--- /dev/null
+++ b/dev-perl/Net-SSLeay/files/Net-SSLeay-1.88-fix-network-tests.patch
@@ -0,0 +1,17 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index 31d9c74..91ac2b4 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -12,11 +12,7 @@ use Symbol qw(gensym);
+ # the Net-SSLeay loadable object on Windows
+ my $win_link_statically = 0;
+
+-my $tests = prompt(
+- "Do you want to run external tests?\n".
+- "These tests *will* *fail* if you do not have network connectivity.",
+- 'n',
+-) =~ /^y/i ? 't/*/*.t t/*/*/*.t' : 't/local/*.t t/handle/local/*.t';
++my $tests = ( 'yes' eq ( $ENV{NETWORK_TESTS} || '' ) ) ? 't/*/*.t t/*/*/*.t' : 't/local/*.t t/handle/local/*.t';
+
+ my %eumm_args = (
+ NAME => 'Net::SSLeay',