summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Net-Twitter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Net-Twitter')
-rw-r--r--dev-perl/Net-Twitter/Manifest2
-rw-r--r--dev-perl/Net-Twitter/Net-Twitter-4.000.60-r1.ebuild42
-rw-r--r--dev-perl/Net-Twitter/Net-Twitter-4.10.80.ebuild57
-rw-r--r--dev-perl/Net-Twitter/metadata.xml30
4 files changed, 131 insertions, 0 deletions
diff --git a/dev-perl/Net-Twitter/Manifest b/dev-perl/Net-Twitter/Manifest
new file mode 100644
index 000000000000..aef0167bfa05
--- /dev/null
+++ b/dev-perl/Net-Twitter/Manifest
@@ -0,0 +1,2 @@
+DIST Net-Twitter-4.00006.tar.gz 126439 SHA256 cf1caaad7b6b5d5fa9abe98bbc2fb88625cdd9a9081ad60cc1e7ffb741b205e9 SHA512 746a4673a10758e9c3c250814d70834f8bd3517185b4790ce047e74a7acd81754eba13dceeada1feb3ca8d2d77a7343cdd24566f18f96e65e77e3e731fb60395 WHIRLPOOL 2dfb567df9e7fcf852d0333cefa725f1678a46bef7f17853c6a534d7a41882e6ff871466dd876da86629e430a12e974917ff10f7ad211ff4f4054dc794cca911
+DIST Net-Twitter-4.01008.tar.gz 129953 SHA256 3c42d3bd61d0850e86e65d1b144fdf137034a6ba509b1a6fb18641381ff85a25 SHA512 7fe7c68f0c8926f398c120ed3ed15e2aba69ec123495eec1fe7b517da7f60f5d192e6f682ee5d36b70ccf0ea55824318b9d74e4add261c93083fcca080d83c65 WHIRLPOOL 5bdea6922ed726a045b5da2e7c6987913f4dcfaa0e81b575a2665a0deaf9d55a2bd7bf6f2940fca8269a5a7d6f186be9f5ee033c207e712fd263b6cdb4c993cb
diff --git a/dev-perl/Net-Twitter/Net-Twitter-4.000.60-r1.ebuild b/dev-perl/Net-Twitter/Net-Twitter-4.000.60-r1.ebuild
new file mode 100644
index 000000000000..90241a8514b5
--- /dev/null
+++ b/dev-perl/Net-Twitter/Net-Twitter-4.000.60-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MMIMS
+MODULE_VERSION=4.00006
+inherit perl-module
+
+DESCRIPTION="A perl interface to the Twitter API"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE=""
+
+RDEPEND=">=dev-perl/Moose-0.94
+ dev-perl/Crypt-SSLeay
+ dev-perl/Data-Visitor
+ >=dev-perl/DateTime-0.51
+ dev-perl/DateTime-Format-Strptime
+ >=dev-perl/Devel-StackTrace-1.21
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Spec
+ dev-perl/HTML-Parser
+ dev-perl/libwww-perl
+ dev-perl/JSON
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Try-Tiny-0.03
+ dev-perl/MooseX-Aliases
+ dev-perl/MooseX-Role-Parameterized
+ >=dev-perl/Net-OAuth-0.25
+ dev-perl/namespace-autoclean
+ >=dev-perl/URI-1.40
+ dev-perl/Carp-Clan"
+
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build"
+
+# online test
+SRC_TEST=skip
diff --git a/dev-perl/Net-Twitter/Net-Twitter-4.10.80.ebuild b/dev-perl/Net-Twitter/Net-Twitter-4.10.80.ebuild
new file mode 100644
index 000000000000..222cc1a5e6b1
--- /dev/null
+++ b/dev-perl/Net-Twitter/Net-Twitter-4.10.80.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MMIMS
+MODULE_VERSION=4.01008
+inherit perl-module
+
+DESCRIPTION="A perl interface to the Twitter API"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Carp-Clan
+ dev-perl/Class-Load
+ dev-perl/Data-Visitor
+ >=dev-perl/DateTime-0.51
+ dev-perl/DateTime-Format-Strptime
+ >=dev-perl/Devel-StackTrace-1.21
+ virtual/perl-Digest-SHA
+ virtual/perl-Encode
+ dev-perl/HTML-Parser
+ dev-perl/HTTP-Message
+ >=dev-perl/IO-Socket-SSL-2.5.0
+ dev-perl/JSON
+ dev-perl/LWP-Protocol-https
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Moose-0.94
+ dev-perl/MooseX-Role-Parameterized
+ dev-perl/Net-HTTP
+ virtual/perl-libnet
+ >=dev-perl/Net-OAuth-0.25
+ virtual/perl-Time-HiRes
+ >=dev-perl/Try-Tiny-0.03
+ >=dev-perl/URI-1.40
+ dev-perl/namespace-autoclean
+"
+
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/libwww-perl
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ dev-perl/Test-Warn
+ )
+"
+
+# online test
+SRC_TEST=skip
diff --git a/dev-perl/Net-Twitter/metadata.xml b/dev-perl/Net-Twitter/metadata.xml
new file mode 100644
index 000000000000..83301c79d35c
--- /dev/null
+++ b/dev-perl/Net-Twitter/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Net-Twitter</remote-id>
+ <remote-id type="cpan-module">Net::Identica</remote-id>
+ <remote-id type="cpan-module">Net::Twitter</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::API</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Core</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Error</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Meta::Method</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::OAuth</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::API::Lists</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::API::REST</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::API::Search</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::API::Search::Trends</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::API::TwitterVision</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::API::Upload</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::AutoCursor</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::InflateObjects</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::Legacy</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::OAuth</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::RateLimit</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::RetryOnError</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::SimulateCursors</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Role::WrapError</remote-id>
+ <remote-id type="cpan-module">Net::Twitter::Search</remote-id>
+ </upstream>
+</pkgmetadata>