summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-29 19:33:12 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-29 19:33:58 +1300
commit201c42c9b3d80d3d7916b37444fbc5cb27cf8776 (patch)
treec67482b8e832e97eb70d9b0f3ae36cab055b2c06 /dev-perl/Net-XMPP/Net-XMPP-1.50.0.ebuild
parentx11-misc/menulibre: Old. (diff)
downloadgentoo-201c42c9b3d80d3d7916b37444fbc5cb27cf8776.tar.gz
gentoo-201c42c9b3d80d3d7916b37444fbc5cb27cf8776.tar.bz2
gentoo-201c42c9b3d80d3d7916b37444fbc5cb27cf8776.zip
dev-perl/Net-XMPP: Fix tests re bug #623002 and bug #612256
- Fix test failures without '.' in @INC (#623002) - Update network-test patch to skip another network test (#612256) - Simplify patching logic - use DIST_EXAMPLES feature for examples Bug: https://bugs.gentoo.org/623002 Bug: https://bugs.gentoo.org/612256 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Net-XMPP/Net-XMPP-1.50.0.ebuild')
-rw-r--r--dev-perl/Net-XMPP/Net-XMPP-1.50.0.ebuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/dev-perl/Net-XMPP/Net-XMPP-1.50.0.ebuild b/dev-perl/Net-XMPP/Net-XMPP-1.50.0.ebuild
index 15a7bce72198..328c35269151 100644
--- a/dev-perl/Net-XMPP/Net-XMPP-1.50.0.ebuild
+++ b/dev-perl/Net-XMPP/Net-XMPP-1.50.0.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=DAPATRICK
DIST_VERSION=1.05
+DIST_EXAMPLES=( "examples/*" )
inherit perl-module
DESCRIPTION="XMPP Perl Library"
@@ -12,7 +13,7 @@ DESCRIPTION="XMPP Perl Library"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="test examples"
+IUSE="test"
RDEPEND="
>=dev-perl/Authen-SASL-2.120.0
@@ -28,16 +29,7 @@ DEPEND="${RDEPEND}
>=virtual/perl-Test-Simple-0.920.0
)
"
-src_test() {
- eapply "${FILESDIR}/${DIST_VERSION}-no-network-tests.patch"
- perl-module_src_test
-}
-
-src_install() {
- perl-module_src_install
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
+PATCHES=(
+ "${FILESDIR}/${DIST_VERSION}-no-network-tests.patch"
+ "${FILESDIR}/${DIST_VERSION}-no-dot-inc.patch"
+)