summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-04-06 04:58:37 +1200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-08 01:07:41 +0200
commita08c30f2224154ef33a7b395e75874e93df5876d (patch)
tree4e54ebf55768658de36cb34f2a6be7da2e6daa31 /dev-perl/POSIX-strftime-Compiler
parentdev-perl/Time-TZOffset: Added at version 0.40.0 (diff)
downloadgentoo-a08c30f2224154ef33a7b395e75874e93df5876d.tar.gz
gentoo-a08c30f2224154ef33a7b395e75874e93df5876d.tar.bz2
gentoo-a08c30f2224154ef33a7b395e75874e93df5876d.zip
dev-perl/POSIX-strftime-Compiler: Bump to version 0.410.0
- EAPI6 - Added optional dep by default for performance - Added USE="examples" Upstream: - Documentaion and packaging fixes Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/POSIX-strftime-Compiler')
-rw-r--r--dev-perl/POSIX-strftime-Compiler/Manifest1
-rw-r--r--dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.410.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/POSIX-strftime-Compiler/Manifest b/dev-perl/POSIX-strftime-Compiler/Manifest
index 9f7e50ede4c4..5edcc9da18fc 100644
--- a/dev-perl/POSIX-strftime-Compiler/Manifest
+++ b/dev-perl/POSIX-strftime-Compiler/Manifest
@@ -1 +1,2 @@
DIST POSIX-strftime-Compiler-0.40.tar.gz 17242 SHA256 7b4abbe793acc920b10ed14f9e430c69ef778e28fd59e4046d6c35d1c24b6c99 SHA512 f646636cc03faac5b14c6b0c2f49292bb85c05d4d244f1d0c8e123885780a14ac2b1a12903883b8c41d056315b0a4928a2d3901dcde585a2bbde72bd61538204 WHIRLPOOL a9cb667a611b105f8e47cef863d15c52177b3a62819ecad91d6f49bd3d1157eca5f41926990be341a1d2e1fbd9a9f5ba2026420a8b0dcb879a68c1b4f0eebdf7
+DIST POSIX-strftime-Compiler-0.41.tar.gz 17187 SHA256 670b89e11500f3808c9e21b1c300089622f68906ff12b1cbfba8e30d3a1c3739 SHA512 b613de3fb332313318cca8a6c8912b64e9dac702d5681d252dc8eb919c7b102354ad25f60b537cdfa66203e01826b34a5a349a2fac856a6affb40d5f160725fe WHIRLPOOL acd4a6cc2829fae3adff94afd07965db665fcea92d3558a10bf29e4b2da5f1bdce37e7893eb6c25fbd9d7925df2445f95b17e3d31fb8c4916054b9a2a217afbe
diff --git a/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.410.0.ebuild b/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.410.0.ebuild
new file mode 100644
index 000000000000..a5788421a394
--- /dev/null
+++ b/dev-perl/POSIX-strftime-Compiler/POSIX-strftime-Compiler-0.410.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=KAZEBURO
+DIST_VERSION=0.41
+
+inherit perl-module
+
+DESCRIPTION="GNU C library compatible strftime for loggers and servers"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal examples"
+
+# POSIX -> perl
+RDEPEND="
+ !minimal? ( dev-perl/Time-TZOffset )
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Time-Local
+"
+
+# CPAN::Meta::Prereqs -> perl-CPAN-Meta
+DEPEND="
+ >=dev-perl/Module-Build-0.380.0
+ virtual/perl-CPAN-Meta
+ ${RDEPEND}
+ test? ( >=virtual/perl-Test-Simple-0.980.0 )
+"
+
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r eg/*
+ fi
+}