summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-24 17:39:17 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:03 +1300
commit4de1315a80012e41dca383af519e11c7424c1e67 (patch)
tree2768dfed436632c33a8f2d02df973a500f25550d /dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild
parentdev-perl/PPI: Bump to version 1.236.0 (diff)
downloadgentoo-4de1315a80012e41dca383af519e11c7424c1e67.tar.gz
gentoo-4de1315a80012e41dca383af519e11c7424c1e67.tar.bz2
gentoo-4de1315a80012e41dca383af519e11c7424c1e67.zip
dev-perl/PPIx-EditorTools: Bump to version 0.200.0
Upstream: - Fixes for '.' in @INC - Lots of packaging changes Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild')
-rw-r--r--dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild
new file mode 100644
index 000000000000..2917e8496957
--- /dev/null
+++ b/dev-perl/PPIx-EditorTools/PPIx-EditorTools-0.200.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=YANICK
+DIST_VERSION=0.20
+inherit perl-module
+
+DESCRIPTION="Utility methods and base class for manipulating Perl via PPI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Class-XSAccessor-1.20.0
+ virtual/perl-File-Spec
+ >=dev-perl/PPI-1.215.0
+ dev-perl/Try-Tiny
+"
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ ${RDEPEND}
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ >=dev-perl/Test-Differences-0.480.100
+ dev-perl/Test-Exception
+ dev-perl/Test-Most
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=("${FILESDIR}/${PN}-0.20-fix-pseudo-deps.patch")