summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Package-Stash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Package-Stash')
-rw-r--r--dev-perl/Package-Stash/Manifest2
-rw-r--r--dev-perl/Package-Stash/Package-Stash-0.340.0.ebuild38
-rw-r--r--dev-perl/Package-Stash/Package-Stash-0.360.0.ebuild38
-rw-r--r--dev-perl/Package-Stash/metadata.xml10
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-perl/Package-Stash/Manifest b/dev-perl/Package-Stash/Manifest
new file mode 100644
index 000000000000..3ea1d45bab8c
--- /dev/null
+++ b/dev-perl/Package-Stash/Manifest
@@ -0,0 +1,2 @@
+DIST Package-Stash-0.34.tar.gz 36180 SHA256 46e6e803c082af9fb4b5b60c242250d33af2316eb3a36df46703376b92fee498 SHA512 e48d37d43699857d2fb5f42aaeade20426e8f83815c99820aaa2d5d812a653bfd9490ad7642d43df5188b1413827233521601251d49abf3286c3c7ce7600f215 WHIRLPOOL 531eb73923f8932e2e326ae2c9135d2ce2a9733650ed3a250f3de1ee411a95a62281c516d6bc57cfbbb5666c1c6dc1b43d9864a1d47e9d3dc72f94892a626e64
+DIST Package-Stash-0.36.tar.gz 37499 SHA256 a01cf48c7cd7a35e0d9ae4b1dc2702698397f55a2ce549d0bdacdc57ea6c73f1 SHA512 117d50fcc16b21171c693f12dce86ad69d34f9cb2d0afe852a077147c3b1115c8ecfc765695236c04728396653e4c0fd4cdae8f2fad03131fbb5d5b471c61b01 WHIRLPOOL f9406c0f70510651e33363bf254fa9adde70d9dcf01c2027ebb82fffa18a24e19570ed0b20687922eef6d9bc4e594e09a74c533cd0f6a17d09d7dffeac6031e1
diff --git a/dev-perl/Package-Stash/Package-Stash-0.340.0.ebuild b/dev-perl/Package-Stash/Package-Stash-0.340.0.ebuild
new file mode 100644
index 000000000000..5e7fcdd7deb5
--- /dev/null
+++ b/dev-perl/Package-Stash/Package-Stash-0.340.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DOY
+MODULE_VERSION=0.34
+inherit perl-module
+
+DESCRIPTION="Routines for manipulating stashes"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ >=dev-perl/Module-Implementation-0.60.0
+ dev-perl/Package-DeprecationManager
+ >=dev-perl/Package-Stash-XS-0.260.0
+"
+# conflicts:
+# !<=dev-perl/Class-MOP-1.08
+# !<=dev-perl/namespace-clean-0.18
+# !<=dev-perl/MooseX-Role-WithOverloading-0.80
+# !<=dev-perl/MooseX-Method-Signatures-0.360.0
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.310.0
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Package-Stash/Package-Stash-0.360.0.ebuild b/dev-perl/Package-Stash/Package-Stash-0.360.0.ebuild
new file mode 100644
index 000000000000..c98d670c38bb
--- /dev/null
+++ b/dev-perl/Package-Stash/Package-Stash-0.360.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DOY
+MODULE_VERSION=0.36
+inherit perl-module
+
+DESCRIPTION="Routines for manipulating stashes"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ >=dev-perl/Module-Implementation-0.60.0
+ dev-perl/Package-DeprecationManager
+ >=dev-perl/Package-Stash-XS-0.260.0
+"
+# conflicts:
+# !<=dev-perl/Class-MOP-1.08
+# !<=dev-perl/namespace-clean-0.18
+# !<=dev-perl/MooseX-Role-WithOverloading-0.80
+# !<=dev-perl/MooseX-Method-Signatures-0.360.0
+
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.310.0
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Package-Stash/metadata.xml b/dev-perl/Package-Stash/metadata.xml
new file mode 100644
index 000000000000..48461dc56cbb
--- /dev/null
+++ b/dev-perl/Package-Stash/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Package-Stash</remote-id>
+ <remote-id type="cpan-module">Package::Stash</remote-id>
+ <remote-id type="cpan-module">Package::Stash::PP</remote-id>
+ </upstream>
+</pkgmetadata>