summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-16 14:21:00 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-16 15:35:02 +1300
commit769e021b6fadf46184dda520eebfe318e2410609 (patch)
treee197c7d55d6f8b8f063ecba7b60b4116e94846f7 /dev-perl/Params-ValidationCompiler
parentdev-perl/DateTime-Set: Bump to 0.390.0 (diff)
downloadgentoo-769e021b6fadf46184dda520eebfe318e2410609.tar.gz
gentoo-769e021b6fadf46184dda520eebfe318e2410609.tar.bz2
gentoo-769e021b6fadf46184dda520eebfe318e2410609.zip
dev-perl/Params-ValidationCompiler: Bump to 0.180.0 (masked)
Upstream: - Now makes a copy of the types if they have coercions in order to avoid "Modification of readonly value" exceptions with positional parameters. - Avoid generation of invalid code with positional Moose type coercions. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/Params-ValidationCompiler')
-rw-r--r--dev-perl/Params-ValidationCompiler/Manifest1
-rw-r--r--dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.180.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Params-ValidationCompiler/Manifest b/dev-perl/Params-ValidationCompiler/Manifest
index 38a3a8deaeb1..79b8838fabe3 100644
--- a/dev-perl/Params-ValidationCompiler/Manifest
+++ b/dev-perl/Params-ValidationCompiler/Manifest
@@ -1 +1,2 @@
DIST Params-ValidationCompiler-0.17.tar.gz 38234 SHA256 b97e5444e866658020221c64c48f02f032012542635f56abde96ba7f19487c6f SHA512 4c909a1034a83bd4a7fe28a0b0c2d1677af848a8a730cef9afe236aa0f4223e3b90b6b5a47e2db9d6b373df95bae8cc9cbf5b46f1e49b99fc34d0665687e261e WHIRLPOOL 8d70518703468e6dab5b51e37521b7042ec5da881d33d31fd88f53c9f438ca544b3eb332792dd8aa0108076e337a5ebf1015fdc6ccca8ed69b05ecd91db901c2
+DIST Params-ValidationCompiler-0.18.tar.gz 38696 SHA256 0e17c193659beca5e9e5a8d040da21faebd6427c6426b94c4094d5d50ceebd9d SHA512 2610e8fa391ee84a76c0c47c958be3ab015f8b511fc6214c9c97d627f5a808e5af6a49c9a10ac0269ec123eb377eda305ae33c667220c3ef9a174fd91671b346 WHIRLPOOL 62ab82b4457940f5c861e059dd76cc488c50841337256580fef2623cbb1f3d350d3b5071783f5a17b4e6a592960c48e4ef3bcf4ad53872e7f1ce453aedd1cd20
diff --git a/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.180.0.ebuild b/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.180.0.ebuild
new file mode 100644
index 000000000000..18c8ac1feb09
--- /dev/null
+++ b/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.180.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.18
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Build an optimized subroutine parameter validator once, use it forever"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Eval-Closure
+ dev-perl/Exception-Class
+ virtual/perl-Exporter
+ >=virtual/perl-Scalar-List-Utils-1.400.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=dev-perl/Specio-0.140.0
+ >=virtual/perl-Test-Simple-1.302.15
+ dev-perl/Test-Without-Module
+ dev-perl/Test2-Suite
+ dev-perl/Test2-Plugin-NoWarnings
+ )
+"