summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-02-14 14:50:06 +1300
committerKent Fredric <kentnl@gentoo.org>2017-02-14 18:18:59 +1300
commit8d11ac4eefdd5cf4ed188a5139e37685e87e5003 (patch)
treed42436a32fd5b62becf992d645efc742fdf427d0 /dev-perl/Params-ValidationCompiler
parentdev-perl/Filter: Bump to version 1.570.0 (diff)
downloadgentoo-8d11ac4eefdd5cf4ed188a5139e37685e87e5003.tar.gz
gentoo-8d11ac4eefdd5cf4ed188a5139e37685e87e5003.tar.bz2
gentoo-8d11ac4eefdd5cf4ed188a5139e37685e87e5003.zip
dev-perl/Params-ValidationCompiler: Bump to version 0.230.0 (masked)
Upstream: - Required positional parameters placed after ones with default now is an error. - Positional Slurpy Parameters with type-coercions now returns coerced values instead of original values Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-perl/Params-ValidationCompiler')
-rw-r--r--dev-perl/Params-ValidationCompiler/Manifest1
-rw-r--r--dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.230.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Params-ValidationCompiler/Manifest b/dev-perl/Params-ValidationCompiler/Manifest
index 0097f1ae66e4..6ff330729456 100644
--- a/dev-perl/Params-ValidationCompiler/Manifest
+++ b/dev-perl/Params-ValidationCompiler/Manifest
@@ -1 +1,2 @@
DIST Params-ValidationCompiler-0.22.tar.gz 39995 SHA256 bbec2b029e8f07801916b8ead4df5016a24daacac7a680f78dfcf70bd8d5f847 SHA512 078b54bc18e840dc19b0cb9f2507728c2977d22276c3ed7b239ea31db91188eac3de69229884a150093c6d70d07872906c545eb044c9d360b96de438c23adf9c WHIRLPOOL ffe4f61faac4aa8ca980ee5a8f72bda04a4b11f1fb183ff25ba42f40e75d2730f8ec316a77e1effb17dc65893bd8172007544d4c67f31d44dc6eb9c9e9984d3b
+DIST Params-ValidationCompiler-0.23.tar.gz 43078 SHA256 e357b63e28950519f227a5b45e4ac1c487cbc6c1bb67c09a8d3698ee9f289230 SHA512 838eec5f94b6bbfcb5d0686da39693f3b78491802683edd4d92893939a887690e1f2f2608c4899b10779b04a64eba33bab5d2f689a96b820cef0b3b2a95fb677 WHIRLPOOL 888e872c78ea45a959ec467a1872f597a7305f5dee222155e2a5d158f58aea901849cedf81f6147291173870302bbea00d89dea23272dce9d1fb64c2268326ed
diff --git a/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.230.0.ebuild b/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.230.0.ebuild
new file mode 100644
index 000000000000..3bf1fc50e113
--- /dev/null
+++ b/dev-perl/Params-ValidationCompiler/Params-ValidationCompiler-0.230.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.23
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Build an optimized subroutine parameter validator once, use it forever"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Eval-Closure
+ dev-perl/Exception-Class
+ virtual/perl-Exporter
+ >=virtual/perl-Scalar-List-Utils-1.400.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=dev-perl/Specio-0.140.0
+ >=virtual/perl-Test-Simple-1.302.15
+ dev-perl/Test-Without-Module
+ dev-perl/Test2-Suite
+ dev-perl/Test2-Plugin-NoWarnings
+ )
+"