summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-26 20:09:46 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:08 +1300
commit713c9226f90553c27ab841c56888a1f50ded5925 (patch)
treea7a82bffc3bd5d20bd5ef2441ceeec31219d605d /dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild
parentdev-perl/Params-ValidationCompiler: Bump to version 0.260.0 (diff)
downloadgentoo-713c9226f90553c27ab841c56888a1f50ded5925.tar.gz
gentoo-713c9226f90553c27ab841c56888a1f50ded5925.tar.bz2
gentoo-713c9226f90553c27ab841c56888a1f50ded5925.zip
dev-perl/Parse-ErrorString-Perl: Bump to version 0.270.0
- Patchify Perl 5.26 fix Upstream: - Documentation fixes - Remove unreachable code Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild')
-rw-r--r--dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild b/dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild
new file mode 100644
index 000000000000..a2b8e197eb18
--- /dev/null
+++ b/dev-perl/Parse-ErrorString-Perl/Parse-ErrorString-Perl-0.270.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MANWAR
+DIST_VERSION=0.27
+inherit perl-module
+
+DESCRIPTION="Parse error messages from the perl interpreter"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-XSAccessor
+ virtual/perl-File-Spec
+ virtual/perl-Pod-Parser
+ >=dev-perl/Pod-POM-0.270.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.59
+ test? (
+ dev-perl/Test-Differences
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+PATCHES=( "${FILESDIR}/${PN}-0.27-no-dot-inc.patch" )