summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-19 18:25:08 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-19 23:41:50 +0100
commit7024d27a87a30922c734f5d7a50eb8736643b447 (patch)
treec84992f66d3b82cd42c22c76f35f59e786121767 /dev-perl/Passwd-Unix/Passwd-Unix-0.710.0.ebuild
parentdev-perl/Struct-Compare: Added to tree at 1.0.1 (diff)
downloadgentoo-7024d27a87a30922c734f5d7a50eb8736643b447.tar.gz
gentoo-7024d27a87a30922c734f5d7a50eb8736643b447.tar.bz2
gentoo-7024d27a87a30922c734f5d7a50eb8736643b447.zip
dev-perl/Passwd-Unix: Added at version 0.710.0
For Monsieurp Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Passwd-Unix/Passwd-Unix-0.710.0.ebuild')
-rw-r--r--dev-perl/Passwd-Unix/Passwd-Unix-0.710.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Passwd-Unix/Passwd-Unix-0.710.0.ebuild b/dev-perl/Passwd-Unix/Passwd-Unix-0.710.0.ebuild
new file mode 100644
index 000000000000..eeb38e51d0b6
--- /dev/null
+++ b/dev-perl/Passwd-Unix/Passwd-Unix-0.710.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=STRZELEC
+DIST_VERSION=0.71
+inherit perl-module
+
+DESCRIPTION="access to standard unix passwd files"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Crypt-PasswdMD5
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ >=virtual/perl-IO-Compress-2.15.0
+ dev-perl/Struct-Compare
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_prepare() {
+ mkdir t/
+ mv test.pl t/test.t
+ sed -i 's|test\.pl$|t/test.t|' MANIFEST
+ perl-module_src_prepare
+}